PAT (Advanced Level) Practise 1026 Table Tennis (30)

1026. Table Tennis (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:
9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2
Sample Output:
08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2

题意:模拟去打乒乓的过程。有n个组要打乒乓,告诉你每个组到达时间,打的时间和是不是vip,并告诉你有几张普通球桌,哪几张为vip球桌,最后按开始打球的时间顺序输出每个组到达的时间,开始打球时间和等待了多少时间。时间超过了21:00就不在服务,也不用输出。最后输出每张球桌服务了多少对人。每队人选球桌有一定规则,若有vip桌子空着,那么在等待的人中vip优先选择vip编号小的球桌,若没有则这队人选择vip编号小的球桌,若只有普通桌子空着,那么这队人选择编号最小的球桌

解题思路:模拟


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, flag[100009], t[100009], x, y, z, m, vis[100009], cnt[100009];

struct point
{
	int x, y, flag;
	bool operator<(const point &a)const
	{
		return x < a.x;
	}
}a[100009];

int main()
{
	while (~scanf("%d", &n))
	{
		for (int i = 0; i < n; i++)
		{
			scanf("%d:%d:%d", &x, &y, &z);
			a[i].x = x * 3600 + y * 60 + z;
			scanf("%d%d", &x, &a[i].flag);
			a[i].y = min(x * 60, 7200);
		}
		memset(vis, 0, sizeof vis);
		memset(flag, 0, sizeof flag);
		sort(a, a + n);
		int p;
		scanf("%d%d", &m, &p);
		for (int i = 1; i <= p; i++)
			scanf("%d", &x), flag[x] = 1;
		for (int i = 1; i <= m; i++) t[i] = 8 * 3600;
		for (int i = 0; i < n; i++)
		{
			if (vis[i]) continue;
			int k = 1;
			for (int j = 1; j <= m; j++)
				if (t[k] > t[j]) k = j;
			if (max(t[k], a[i].x) >= 21 * 3600) break;
			if (t[k] <= a[i].x) 
			{
				int vip = -1;
				for (int j = m; j >= 1; j--)
				{
					if (t[j] <= a[i].x) k = j;
					if (t[j] <= a[i].x&&flag[j]) vip = j;
				}
				if (a[i].flag&&vip != -1) k = vip;
				cnt[k]++;
				printf("%02d:%02d:%02d ", a[i].x / 3600, a[i].x / 60 % 60, a[i].x % 60);
				printf("%02d:%02d:%02d ", a[i].x / 3600, a[i].x / 60 % 60, a[i].x % 60);
				printf("0\n"); t[k] = a[i].x + a[i].y;
			}
			else
			{
				int vip = -1;
				for (int j = m; j >= 1; j--)
					if (t[j] == t[k] && flag[j]) vip = j;
				if (vip != -1)
				{
					int flag = 0;
					for (int j = i; j < n&&a[j].x <= t[vip]; j++)
					{
						if (a[j].flag && !vis[j])
						{
							vis[j] = 1;
							printf("%02d:%02d:%02d ", a[j].x / 3600, a[j].x / 60 % 60, a[j].x % 60);
							printf("%02d:%02d:%02d ", t[vip] / 3600, t[vip] / 60 % 60, t[vip] % 60);
							printf("%d\n", (t[vip] - a[j].x) / 60 + ((t[vip] - a[j].x) % 60 < 30 ? 0 : 1));
							t[vip] = t[vip] + a[j].y;
							flag = 1; break;
						}
					}
					cnt[vip]++;
					if (flag) i--;
					else
					{
						printf("%02d:%02d:%02d ", a[i].x / 3600, a[i].x / 60 % 60, a[i].x % 60);
						printf("%02d:%02d:%02d ", t[k] / 3600, t[k] / 60 % 60, t[k] % 60);
						printf("%d\n", (t[k] - a[i].x) / 60 + ((t[k] - a[i].x) % 60 < 30 ? 0 : 1));
						t[k] = t[k] + a[i].y;
					}
				}
				else
				{
					cnt[k]++;
					printf("%02d:%02d:%02d ", a[i].x / 3600, a[i].x / 60 % 60, a[i].x % 60);
					printf("%02d:%02d:%02d ", t[k] / 3600, t[k] / 60 % 60, t[k] % 60);
					printf("%d\n", (t[k] - a[i].x) / 60 + ((t[k] - a[i].x) % 60 < 30 ? 0 : 1));
					t[k] = t[k] + a[i].y;
				}
			}
		}
		for (int i = 1; i <= m; i++) printf("%d%s", cnt[i], i == m ? "\n" : " ");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值