有一间长方形的房子,地上铺了红色、黑色两种颜色的正方形瓷砖。你站在其中一块黑色的瓷砖上,只能向相邻的黑色瓷砖移动。请写一个程序,计算你总共能够到达多少块黑色的瓷砖。Input包括多个数据集合。每个数据集合的第一行是两个整数W和H,分别表示x方向和y方向瓷砖的数量。W和H都不超过20。在接下来的H行中,每行包括W个字符。每个字符表示一块瓷砖的颜色,规则如下
1)‘.’:黑色的瓷砖;
2)‘#’:白色的瓷砖;
3)‘@’:黑色的瓷砖,并且你站在这块瓷砖上。该字符在每个数据集合中唯一出现一次。
当在一行中读入的是两个零时,表示输入结束。
Output对每个数据集合,分别输出一行,显示你从初始位置出发能到达的瓷砖数(记数时包括初始位置的瓷砖)。Sample Input
1)‘.’:黑色的瓷砖;
2)‘#’:白色的瓷砖;
3)‘@’:黑色的瓷砖,并且你站在这块瓷砖上。该字符在每个数据集合中唯一出现一次。
当在一行中读入的是两个零时,表示输入结束。
Output对每个数据集合,分别输出一行,显示你从初始位置出发能到达的瓷砖数(记数时包括初始位置的瓷砖)。Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 0 0Sample Output
45
AC代码:
#include<iostream>
#include<map>
#include<iterator>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
char mapp[22][22];
int res;
vector<vector<bool> > vis(30,vector<bool>(30,false));
int nextt[4][2]={ {1,0},{-1,0},{0,1},{0,-1} };
vector<int> write( int H , int W ){
vector<int> tt;
for( int i = 0 ; i < W ; i ++ ){
for( int j = 0 ; j < H ; j ++ ){
cin >> mapp[i][j];
if( mapp[i][j] == '@' )
{
tt.push_back(i);
tt.push_back(j);
}
}
cin.ignore();
}
return tt;
}
void dfs( int x , int y , int W , int H ){
if( mapp[x][y] == '#' )
return ;
if( mapp[x][y] == '.' )
res ++;
for( int k = 0 ; k < 4 ; k ++ ){
int tx = x + nextt[k][0];
int ty = y + nextt[k][1];
if( tx < 0 || ty < 0 || tx >= H || ty >= W ) //越界
continue;
if( !vis[tx][ty] && mapp[tx][ty] == '.' )
{
vis[tx][ty] = true;
dfs(tx,ty,W,H);
}
}
}
int main()
{
int W,H;
int x , y;
while( cin >> W >> H && W != 0 && H != 0 )
{
vector<int> t = write(W,H);
x = t[0];
y = t[1];
vis[x][y] = true;
dfs(x,y,W,H);
cout << res + 1 << endl;
res = 0;
for( int i = 0 ; i < vis.size() ; i ++ )
fill(vis[i].begin(),vis[i].end(),false);
}
return 0;
}