uva_1368_DNA

Figure 1.

Description

DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:
``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"
Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.


Figure 2. DNA sequences of gene X in five animals.

Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,..., sm of length n , the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of S . For example, given the three strings ``AGCAT" ``AGACT" and ``GGAAT" the consensus string of the given strings is ``AGAAT" because the sum of the Hamming distances between ``AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is ``GCAAATGGCTGTGCA" and the consensus error is 7.

Intput

Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the input. Each test case starts with a line containing two integers m and nwhich are separated by a single space. The integer m (4$ \le$m$ \le$50) represents the number of DNA sequences andn (4$ \le$n$ \le$1000) represents the length of the DNA sequences, respectively. In each of the next m lines, each DNA sequence is given.

Output

Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input and output for three test cases.

Sample Input

3 
5 8 
TATGATAC 
TAAGCTAC 
AAAGATCC 
TGAGATAC 
TAAGATGT 
4 10 
ACGTACGTAC 
CCGTACGTAG 
GCGTACGTAT 
TCGTACGTAA 
6 10 
ATGTTACCAT 
AAGTTACGAT 
AACAAAGCAA 
AAGTTACCTT 
AAGTTACCAA 
TACTTACCAA

Sample Output

TAAGATAC 
7 
ACGTACGTAA 
6 
AAGTTACCAA 
12
总结:

注意要最大值相同的话要用字典序排序,所以用ACGT 相当于数组的0123 

代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    int cou,m,n,i,j,a[4][1002]/*1A2T3G4C*/,max,maxi,error;
    char dna[52][1002],rdna[1002];
    scanf("%d",&cou);
    while(cou--)
    {
        error=0;
        memset(a,0,sizeof(a));
        scanf("%d%d",&m,&n);
        for(i=0;i<m;i++)
            scanf("%s",dna[i]);
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                switch(dna[i][j])
                {
                    case 'A': a[0][j]++;continue;
                    case 'C': a[1][j]++;continue;
                    case 'G': a[2][j]++;continue;
                    case 'T': a[3][j]++;continue;
                    default:continue;

                }
            }
        }
        max=a[0][0];
        maxi=0;
        for(i=0;i<n;i++)
        {
            max=0;
            maxi=0;
            for(j=0;j<4;j++)
            {
                if(max<a[j][i])
                {
                    max=a[j][i];
                    maxi=j;
                }
                else if(max==a[j][i]&&maxi>j)
                    maxi=j;
            }
            switch(maxi)
            {
                case 0:rdna[i]='A';break;
                case 1:rdna[i]='C';break;
                case 2:rdna[i]='G';break;
                case 3:rdna[i]='T';break;
            }
        }
        rdna[i]='\0';
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(dna[i][j]!=rdna[j])
                    error++;
            }
        }
        puts(rdna);
        printf("%d\n",error);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值