POJ1008My Calendar两种日历年月日间的转换月份用字符数组表示

本文介绍了一款程序,该程序能够将玛雅文明中使用的Haab日历日期转换为Tzolkin日历日期。Haab日历由19个月组成,每月20天,而Tzolkin日历则分为13个周期,每个周期20天。通过解析输入文件中的日期格式,程序计算出对应的Tzolkin日历日期。
摘要由CSDN通过智能技术生成

Description

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

Haab: 0. pop 0

Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

Input

The date in Haab is given in the following format:
NumberOfTheDay. Month Year

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

Output

The date in Tzolkin should be in the following format:
Number NameOfTheDay Year

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

Sample Input

3
10. zac 0
0. pop 0
10. zac 1995

Sample Output

3
3 chuen 0
1 imix 0

9 cimi 2801

AC代码:

#include <iostream>
#include<string.h>
#include<cstdio>
using namespace std;
const char mh[19][20]= {"pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen", "yax", "zac",
                        "ceh", "mac","kankin", "muan", "pax", "koyab","cumhu","uayet"
                       };
const char mt[20][20]= {"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok",
                        "chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"
                       };
int main()
{//题意就是将19个月,每个月20天,19个月份名字已用字符串表示出的Haab日历换成使用13个数字num,单词共有20个的Tzolkin日历
    int i,date,year,t,num,word,T;//t是总天数,换算前后t不变
    char c;
    string month;
    cin>>T;
    cout<<T<<endl;
    while(T--)
    {
        cin>>date>>c>>month>>year;//c为任意字符
        for(i=0; i<19; i++)//19个月
            if(month==mh[i])//这一句是字符数组转化为具体天数的关键
                t=365*year+i*20+date+1;//天数规定表示为为0-19,即从0天开始
        if(t%260==0)
        {
            year=t/260-1;
            num=13;
            word=20;
        }
        else
        {
            year=t/260;
            num=(t%13==0?13:t%13);//num是1-13
            word=(t-1)%20+1;
        }
        cout<<num<<" "<<mt[--word]<<" "<<year<<endl;
    }
    return 0;
}

学习心得:月份用字符数组表示,string month,if(month==mh[i])转换很重要

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值