hdu 5347

18 篇文章 0 订阅
MZL's chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 320

Problem Description
MZL define F(X) as the first ionization energy of the chemical element X
Now he get two chemical elements U,V,given as their atomic number,he wants to compare F(U) and F(V)
It is guaranteed that atomic numbers belongs to the given set:{1,2,3,4,..18,35,36,53,54,85,86}
It is guaranteed the two atomic numbers is either in the same period or in the same group
It is guaranteed that x≠y
 
Input
There are several test cases
For each test case,there are two numbers u,v,means the atomic numbers of the two element
 
Output
For each test case,if F(u)>F(v),print "FIRST BIGGER",else print"SECOND BIGGER"
 
Sample Input
1 2
5 3

Sample Output
SECOND BIGGER

FIRST BIGGER


//根据第一电离能变化规律打表

#include <stdio.h>
#include <string.h>
int a[200];

int main()
{
    memset(a,0,sizeof(a));
    a[1]=1100,a[2]=1101;
    for(int i=3;i<=10;i++)
        a[i]=i*100;
    for(int k=11;k<=18;k++)
        a[k]=k;
    a[35]=15,a[36]=16;
    a[53]=12,a[54]=13;
    a[83]=10,a[84]=11;
    a[4]=500,a[5]=400,a[7]=800,a[8]=700;
    a[12]=13,a[13]=12,a[15]=16,a[16]=15;
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(a[n]>a[m])
            printf("FIRST BIGGER\n");
        else
            printf("SECOND BIGGER\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值