HDU 5347 MZL's chemistry (2015 Multi-University Training Contest 5 2015多校联合)

题目传送门:HDU 5347 MZL's chemistry

MZL's chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 32    Accepted Submission(s): 29


Problem Description
MZL define  F(X)  as the first ionization energy of the chemical element  X

Now he get two chemical elements  U,V ,given as their atomic number,he wants to compare  F(U)  and  F(V)

It is guaranteed that atomic numbers belongs to the given set: {1,2,3,4,..18,35,36,53,54,85,86}

It is guaranteed the two atomic numbers is either in the same period or in the same group

It is guaranteed that  xy
 

Input
There are several test cases

For each test case,there are two numbers  u,v ,means the atomic numbers of the two element
 

Output
For each test case,if  F(u)>F(v) ,print "FIRST BIGGER",else print"SECOND BIGGER"
 

Sample Input
  
  
1 2 5 3
 

Sample Output
  
  
SECOND BIGGER FIRST BIGGER
 

Source
 

高中生出的题= =。啊。找来那个第一电离能的表直接打表就出结果了。

代码:

#include"iostream"
#include"cstdio"
using namespace std;
int main()
{
    int u,v;
    int a[104]={1312.0,2372.3,520.2,899.5,800.6,1086.5,1402.3,1313.9,1681.0,2080.7,
                695.8,737.7,577.5,786.5,1011.8,999.6,1251.2,1520.6,418.8,589.8,
                633.1,658.8,650.9,652.9,717.3,762.5,760.4,737.1,745.5,906.4,
                57.8,762.0,794.0,941.0,1139.9,1350.8,403.0,549.5,900.0,640.1,
                652.1,684.3,702.0,710.2,719.7,804.4,781.0,867.8,558.3,708.6,
                834.0,869.3,1008.4,1170.4,375.7,502.9,538.1,534.4,527.0,533.1,
                540.0,544.5,547.1,593.4,565.8,573.0,581.0,589.3,596.7,603.4,
                523.5,658.5,761.0,770.0,760.0,840.0,880.0,870.0,890.1,1007.1,
                589.4,715.6,703.0,812.1,890.0,1037.0};
    while(scanf("%d%d",&u,&v)!=EOF)
    {
        if(a[u-1]>a[v-1])
        {
            printf("FIRST BIGGER\n");
        }
        else
        {
            printf("SECOND BIGGER\n");
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值