HDU 5437

8 篇文章 0 订阅

Alisha’s Party

                                                            Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                         Total Submission(s): 2342    Accepted Submission(s): 638


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value  v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let  p  people enter her castle. If there are less than  p  people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query  n  Please tell Alisha who the  nth  person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,  T  , where  1T15 .

In each test case, the first line contains three numbers  k,m  and  q  separated by blanks.  k  is the number of her friends invited where  1k150,000 . The door would open m times before all Alisha’s friends arrive where  0mk . Alisha will have  q  queries where  1q100 .

The  ith  of the following  k  lines gives a string  Bi , which consists of no more than  200  English characters, and an integer  vi 1vi108 , separated by a blank.  Bi  is the name of the  ith  person coming to Alisha’s party and Bi brings a gift of value  vi .

Each of the following  m  lines contains two integers  t(1tk)  and  p(0pk)  separated by a blank. The door will open right after the  tth  person arrives, and Alisha will let  p  friends enter her castle.

The last line of each test case will contain  q  numbers  n1,...,nq  separated by a space, which means Alisha wants to know who are the  n1th,...,nqth  friends to enter her castle.

Note: there will be at most two test cases containing  n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
   
   
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
   
   
Sorey Lailah Rose
 

//排序后放入优先队列
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=150000+10;
const int inf=(1<<30);

struct Node
{
    char s[300];
    int val;
    int i;
    friend bool operator < (const Node &a,const Node &b)
    {
        if(a.val==b.val)
            return a.i>b.i;
        return a.val<b.val;
    }
}p[maxn];

struct node
{
    int tol,conum;
}q[maxn];
bool cmp(node a,node b)
{
    return a.tol<b.tol;
}
int ans[maxn];
int main()
{
    int k,m,n,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(ans,0,sizeof(ans));
        scanf("%d%d%d",&k,&m,&n);
        for(int i=0;i<k;i++)
        {
            scanf("%s%d",p[i].s,&p[i].val);
            p[i].i=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&q[i].tol,&q[i].conum);
        }
        sort(q,q+m,cmp);
        priority_queue <Node> qu;
        int cnt,cnt1;
        cnt=0,cnt1=1;
        for(int i=0;i<k;i++)
        {
            qu.push(p[i]);
            if(cnt<m&&i==q[cnt].tol-1)
            {
                while(q[cnt].conum--&&!qu.empty())
                {
                    ans[cnt1++]=qu.top().i;
                    qu.pop();
                }
                cnt++;
            }
        }
        while(!qu.empty())
        {
            ans[cnt1++]=qu.top().i;
            qu.pop();
        }
        while(n--)
        {
            int res;
            scanf("%d",&res);
            if(n==0)
                printf("%s\n",p[ans[res]].s);
            else
                printf("%s ",p[ans[res]].s);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值