HDU 1394(逆序数)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14950    Accepted Submission(s): 9138


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

//逆序数的应用
//树状数组

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=5000+10;
const int inf=(1<<30);
int n,c[maxn];
int arr[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void add(int i,int val)
{
    while(i<=n)
    {
        c[i]+=val;
        i+=lowbit(i);
    }
}

int sum(int i)
{
    int sum=0;
    while(i)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int ans=0;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",arr+i);
            add(arr[i]+1,1);
            ans+=(i-sum(arr[i]+1));
        }
        int sum=ans;
        for(int i=1;i<=n;i++)
        {
            sum-=arr[i];
            sum+=n-arr[i]-1;  // res=t-sum(arr[i])+n-(arr[i]+1); 减去小于它的个数加上大于它的个数
            ans=min(ans,sum);
        }
        printf("%d\n",ans);
    }
    return 0;
}

//线段树
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=5000+10;
const int inf=(1<<30);
int num;
int arr[maxn];
struct Node
{
    int r,l;
    int num;
    int mid()
    {
        return (r+l)/2;
    }
}tree[maxn];

void Buildtree(int rt,int l,int r)
{
    tree[rt].l=l;
    tree[rt].r=r;
    tree[rt].num=0;
    if(l!=r)
    {
        Buildtree(2*rt,l,(l+r)/2);
        Buildtree(2*rt+1,(l+r)/2+1,r);
    }
}

void Update(int rt,int num,int val)
{
    if(tree[rt].l==tree[rt].r&&tree[rt].r==num)
    {
        tree[rt].num=val;
        return;
    }
    if(num<=tree[rt].mid())
        Update(2*rt,num,val);
    else
        Update(2*rt+1,num,val);
    tree[rt].num=tree[rt*2].num+tree[rt*2+1].num;
}
void Query(int rt,int l,int r)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    {
        num+=tree[rt].num;
        return;
    }
    if(r<=tree[rt].mid())
        Query(2*rt,l,r);
    else if(l>tree[rt].mid())
        Query(2*rt+1,l,r);
    else
    {
        Query(2*rt,l,tree[rt].mid());
        Query(2*rt+1,tree[rt].mid()+1,r);
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        Buildtree(1,0,n-1);
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            num=0;
            scanf("%d",arr+i);
            Query(1,arr[i],n-1);
            sum+=num;
            Update(1,arr[i],1);
        }
        int res=0;
        int ans=sum;
        for(int i=1;i<=n;i++)
        {
            sum-=arr[i];
            sum+=n-arr[i]-1;
            ans=min(ans,sum);
        }
        printf("%d\n",ans);
    }
    return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值