hdu 5636(最短路)

16 篇文章 0 订阅

Shortest Path

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1178    Accepted Submission(s): 369


Problem Description
There is a path graph  G=(V,E)  with  n  vertices. Vertices are numbered from  1  to  n  and there is an edge with unit length between  i  and  i+1   (1i<n) . To make the graph more interesting, someone adds three more edges to the graph. The length of each new edge is  1 .

You are given the graph and several queries about the shortest path between some pairs of vertices.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integer  n  and  m   (1n,m105)  -- the number of vertices and the number of queries. The next line contains 6 integers  a1,b1,a2,b2,a3,b3   (1a1,a2,a3,b1,b2,b3n) , separated by a space, denoting the new added three edges are  (a1,b1) (a2,b2) (a3,b3) .

In the next  m  lines, each contains two integers  si  and  ti   (1si,tin) , denoting a query.

The sum of values of  m  in all test cases doesn't exceed  106 .
 

Output
For each test cases, output an integer  S=(i=1mizi) mod (109+7) , where  zi  is the answer for  i -th query.
 

Sample Input
  
  
1 10 2 2 4 5 7 8 10 1 5 3 1
 

Sample Output
  
  
7
 

Source
// 将6个点重新用a[1]..a[6]标记 用floyd算出之间的最短路 接着每次输入两个点的时候求出最短的路径
#include <stdio.h>
#include <iostream>
#include <cmath>
using namespace std;
const __int64 inf=(1<<28);
__int64 Mod = 1000000007;
int a[10];
int ma[10][10];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0;i<7;i++)
            for(int k=0;k<7;k++)
                ma[i][k]=inf;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<7;i++)
            scanf("%d",a+i);
        for(int i=1;i<7;i++)
            for(int k=1;k<7;k++)
                ma[i][k]=abs(a[i]-a[k]);
        ma[1][2]=ma[2][1]=1;
        ma[3][4]=ma[4][3]=1;
        ma[5][6]=ma[6][5]=1;
        for(int k=1;k<7;k++)
            for(int j=1;j<7;j++)
                for(int jj=1;jj<7;jj++)
                    if(ma[j][jj]>ma[j][k]+ma[k][jj])
                        ma[j][jj]=ma[j][k]+ma[k][jj];
        __int64 sum=0;
        for(long long i=1;i<=m;i++)
        {
            int u,v,res=0;
            scanf("%d%d",&u,&v);
            res=abs(u-v);
            for(int k=1;k<7;k++) //暴力一遍 看看能否取得更小的最短路
                for(int j=1;j<7;j++)
                {
                    res=min(res,int(abs(u-a[k])+ma[k][j]+abs(a[j]-v)));
                    res=min(res,int(abs(v-a[k])+ma[k][j]+abs(a[j]-u)));
                }
            res=(res*i)%Mod;
          //  printf("%d\n",res);
            sum=(sum+res)%Mod;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值