HDU 5636

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=5636

Shortest Path

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 335    Accepted Submission(s): 105


Problem Description
There is a path graph  G=(V,E)  with  n  vertices. Vertices are numbered from  1  to  n  and there is an edge with unit length between  i  and  i+1   (1i<n) . To make the graph more interesting, someone adds three more edges to the graph. The length of each new edge is  1 .

You are given the graph and several queries about the shortest path between some pairs of vertices.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integer  n  and  m   (1n,m105)  -- the number of vertices and the number of queries. The next line contains 6 integers  a1,b1,a2,b2,a3,b3   (1a1,a2,a3,b1,b2,b3n) , separated by a space, denoting the new added three edges are  (a1,b1) (a2,b2) (a3,b3) .

In the next  m  lines, each contains two integers  si  and  ti   (1si,tin) , denoting a query.

The sum of values of  m  in all test cases doesn't exceed  106 .
 

Output
For each test cases, output an integer  S=(i=1mizi) mod (109+7) , where  zi  is the answer for  i -th query.
 

Sample Input
  
  
1 10 2 2 4 5 7 8 10 1 5 3 1
 

Sample Output
  
  
7
 


题意:给出一条长为n的链,相邻的两个可通过1代价互相传送,同时给出三个传送门,两边的点均可通过1代价传过去

进行m次询问,每次给出a,b,求从a到b的最小代价


把三个传送门给的6个点当成节点做一次 floyd,然后每次把6个节点遍历一遍即可...


上面是题解...复杂度为o(6^2*m),讲道理啊。。我写了一个o(6^3*m)就超时了,有必要卡那么严格吗╮(╯_╰)╭

然后dmax一开始赋值为x-y的绝对值,结果还没输入就被赋值了。。结果样例还看不出来。。改了半小时。。。

下面代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<functional>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;

__int64 qfabs(__int64 n)
{
	if(n<0) return -n;
	return n;
}

__int64 dmap[20][20];

int main()
{
	int nn,ii,i,j,k,m,n;
	__int64 sum,dmax,ans,x,y,a[10],b[10];
	
	scanf("%d",&nn);
	__int64 l=1e+9+7;
	while(nn--)
	{
		ans=0;
		memset(a,0,sizeof(a));
		memset(dmap,0,sizeof(dmap));
		scanf("%d%d",&m,&n);
		for(i=1;i<=3;i++)
		{
			scanf("%I64d%I64d",&a[i],&b[i]);
			a[i+3]=b[i];
		}
		
		for(i=1;i<=6;i++)
			for(j=1;j<=6;j++)
			dmap[i][j]=qfabs(a[i]-a[j]);
		for(i=1;i<=3;i++)
			dmap[i][i+3]=dmap[i+3][i]=1;
		for(k=1;k<=6;k++)
			for(i=1;i<=6;i++)
				for(j=1;j<=6;j++)
					if(dmap[i][j]>dmap[i][k]+dmap[k][j]) dmap[i][j]=dmap[i][k]+dmap[k][j];
		
		for(ii=1;ii<=n;ii++)
		{
			scanf("%I64d%I64d",&x,&y);
			dmax=qfabs(x-y);
			for(i=1;i<=6;i++)
				for(j=1;j<=6;j++)
				{
					sum=qfabs(a[i]-x)+dmap[i][j]+qfabs(a[j]-y);
					if(sum<dmax) dmax=sum;
				}
			ans=(ans+(dmax*ii))%l;
		}
		
		printf("%I64d\n",ans);
	}
	
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值