Matrix
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 768 Accepted Submission(s): 323
Problem Description
There is a matrix
M
that has
n
rows and
m
columns
(1≤n≤1000,1≤m≤1000)
.Then we perform
q(1≤q≤100,000)
operations:
1 x y: Swap row x and row y (1≤x,y≤n) ;
2 x y: Swap column x and column y (1≤x,y≤m) ;
3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000) ;
4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000) ;
1 x y: Swap row x and row y (1≤x,y≤n) ;
2 x y: Swap column x and column y (1≤x,y≤m) ;
3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000) ;
4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000) ;
Input
There are multiple test cases. The first line of input contains an integer
T(1≤T≤20)
indicating the number of test cases. For each test case:
The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1≤Mi,j≤10,000) for all (1≤i≤n,1≤j≤m) .
The following q lines contains three integers a(1≤a≤4) , x and y .
The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1≤Mi,j≤10,000) for all (1≤i≤n,1≤j≤m) .
The following q lines contains three integers a(1≤a≤4) , x and y .
Output
For each test case, output the matrix
M
after all
q
operations.
Sample Input
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
Sample Output
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1HintRecommand to use scanf and printf
Source
//开四个数组记录行列变换。。还有相加的值
#include <bits/stdc++.h>
using namespace std;
#define ll long long
ll ma[1005][1005];
ll row[1005],col[1005],sumr[1005],sumc[1005];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
ll n,m,q;
scanf("%lld%lld%lld",&n,&m,&q);
memset(sumr,0,sizeof(sumr));
memset(sumc,0,sizeof(sumc));
for(int i=1;i<=n;i++)
{
row[i]=i;
for(int k=1;k<=m;k++)
{
scanf("%lld",&ma[i][k]);
col[k]=k;
}
}
while(q--)
{
ll type,x,y;
scanf("%lld%lld%lld",&type,&x,&y);
if(type==1)
{
swap(row[x],row[y]);
swap(sumr[x],sumr[y]);
}
else if(type==2)
{
swap(col[x],col[y]);
swap(sumc[x],sumc[y]);
}
else if(type==3)
{
sumr[x]+=y;
}
else
{
sumc[x]+=y;
}
}
for(int i=1;i<=n;i++)
{
for(int k=1;k<=m-1;k++)
{
ll t=ma[row[i]][col[k]]+sumr[i]+sumc[k];
printf("%lld ",t);
}
printf("%lld\n",ma[row[i]][col[m]]+sumr[i]+sumc[m]);
}
}
return 0;
}