HDU 5671 Matrix(思维题目,记录变化)

109 篇文章 0 订阅
16 篇文章 0 订阅

Matrix

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 725 Accepted Submission(s): 304

Problem Description
There is a matrix M that has n rows and m columns (1≤n≤1000,1≤m≤1000).Then we perform q(1≤q≤100,000) operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);

Input
There are multiple test cases. The first line of input contains an integer T(1≤T≤20) indicating the number of test cases. For each test case:

The first line contains three integers n, m and q.
The following n lines describe the matrix M.(1≤Mi,j≤10,000) for all (1≤i≤n,1≤j≤m).
The following q lines contains three integers a(1≤a≤4), x and y.

Output
For each test case, output the matrix M after all q operations.

Sample Input
2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

Sample Output
12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

用四个一维数组存储修改的东西。在最后输出的时候再处理就行了。
下面是AC代码,有什么问题的话可以评论,在最短时间内会回的。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int a[1005][1005];
int sx[1005],sy[1005],ax[1005],ay[1005];

int main()
{
    int t,n,m,q;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&q);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
                scanf("%d",&a[i][j]);
        }
        int maxn=max(n,m);
        for(int i=1; i<=maxn; i++)
        {
            sx[i]=i;
            sy[i]=i;
            ax[i]=0;
            ay[i]=0;
        }
        while(q--)
        {
            int num,t1,t2;
            scanf("%d%d%d",&num,&t1,&t2);
            if(num==1)
            {
                swap(sx[t1],sx[t2]);
            }
            else if(num==2)
            {
                swap(sy[t1],sy[t2]);
            }
            else if(num==3)
            {
                ax[sx[t1]]+=t2;
            }
            else if(num==4)
            {
                ay[sy[t1]]+=t2;
            }
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<m; j++)
            {
                printf("%d ",a[sx[i]][sy[j]]+ax[sx[i]]+ay[sy[j]]);
            }
            printf("%d\n",a[sx[i]][sy[m]]+ax[sx[i]]+ay[sy[m]]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值