hdu 4565(矩阵快速幂)

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3675    Accepted Submission(s): 1194


Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14 4
 

Source

#include <bits/stdc++.h>
using namespace std;
#define ll long long
ll Mod;

struct Matrix
{
    ll ma[2][2];
    void init(ll a,ll b,ll c,ll d){
        ma[0][0]=a;ma[0][1]=b;
        ma[1][0]=c;ma[1][1]=d;
    }
    Matrix(){
        memset(ma,0,sizeof(ma));
    }
    Matrix operator * (const Matrix &m){
        Matrix res;
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++)
                for(int k=0;k<2;k++)
                    res.ma[i][j]=(res.ma[i][j]+m.ma[i][k]*ma[k][j])%Mod;
        return res;
    }
};

Matrix quick_powm(Matrix m,ll n)
{
    if(n==1)return m;
    Matrix res=quick_powm(m,n/2);
    Matrix ans=res*res;
    if(n%2==1)
        ans=ans*m;
    return ans;
}

int main()
{
    ll a,b,n;
    while(~scanf("%lld%lld%lld%lld",&a,&b,&n,&Mod))
    {
        Matrix m,res;
        m.init(a,1,b,a);
        res=quick_powm(m,n);
        printf("%lld\n",(2*res.ma[0][0])%Mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值