STL-B The Blocks Problem

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks. In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands. The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n − 1) with block bi adjacent to block bi+1 for all 0 ≤ i < n − 1 as shown in the diagram below: 在这里插入Initial BlocksWorld图片描述 The valid commands for the robot arm that manipulates blocks are: • move a onto b where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions. • move a over b where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions. • pile a onto b where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved. • pile a over b where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved. • quit terminates manipulations in the block world. Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25. The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered. You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

The output should consist of the final state of the blocks world. Each original block position numbered i (0 ≤ i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don’t put any trailing spaces on a line. There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

题的意思是,定义n个堆,根据不同的指令移动木块,最后输出每个堆所包含的木块。这个题思路想起来简单,但写起来却十分困难。首先定义30个堆,每一个堆都是一个vector。然后用不同的函数写不同的指令。具体代码如下:

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>pile[30];//定义最多有30个vector
int n;
void find_block(int num,int &p,int &h)//找到编号为num的堆p和高度h
{
    for (int i=0; i<n;++i)
        for (int j=0;j<pile[i].size();j++)
        {
            if (pile[i][j]==num)
            {
                p=i;
                h=j;
                return;
            }
        }
}
void clear_above(int p,int h)//把第p堆在高度h之上的木块移回原处
{
    for (int i=h+1;i<pile[p].size();++i)
    {
        int x=pile[p][i];
        pile[x].push_back(x);//移回原位
    }
    pile[p].resize(h+1);//删除h和h上面的元素,只保留下标0~h-1的元素
}
void pile_upon(int p1,int h1,int p2)//输出函数
{
    for (int i=h1;i<pile[p1].size();++i)
    pile[p2].push_back(pile[p1][i]);
    pile[p1].resize(h1);
}
void print_status()
{
    for (int i=0;i<n;++i)
    {
        printf("%d:",i);
        for (int j=0;j<pile[i].size();++j)
            printf(" %d",pile[i][j]);
        printf("\n");
    }
}

int main()
{
    cin>>n;
    string s1,s2;
    int a,b;
    for (int i=0;i<n;++i) pile[i].push_back(i);
    while(cin>>s1>>a>>s2>>b)
    {

        int pa,pb,ha,hb;
        find_block(a,pa,ha);//找到数字a
        find_block(b,pb,hb);//找到数字b
        if (pa==pb)//非法指令
        continue;
        if (s1=="move")//要move a一定会归位a上面的木块
        clear_above(pa,ha);//要onto b一定会归位b上面的木块
        if (s2=="onto")
        clear_above(pb,hb);
        pile_upon(pa,ha,pb);//把a及其之上的木块移到b堆上
    }
    print_status();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值