贪心-C

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

在这里插入图片描述

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题的意思是在一个平面直角坐标系中,x轴的上半部分是海,海上有n个岛屿,现要在x轴上建设雷达来检测这些岛屿,问最少要放多少个雷达才能全面覆盖。每个雷达可检测的半径是d,下面输入n组数据,每组数据有两个数,分别代表每个小岛的横纵坐标。
首先当输入的纵坐标y大于半径d时,无法覆盖到这个小岛,输出-1;如果y<d,则根据数学公式求出,以小岛为圆心,以d为半径作圆,求出该圆与x轴的交点坐标。然后把这些坐标按照左交点升序排列,若左交点相同,则按右交点升序排列。最后进行判断,看两个岛屿之间是否有相交的区域,这个区域中建设一个雷达便可以同时检测两个岛屿。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct island
{
    double left;
    double right;
}a[1005];
bool cmp(island a,island b)//把这些坐标按照左交点升序排列,若左交点相同,则按右交点升序排列
{
    if(a.left==b.left)
    return a.right<b.right;
    else
    return
    a.left<b.left;
}
int main()
{
    int n;
    double d;
    double x,y;
    int Case=1;
    while((cin>>n>>d)&&(n!=0||d!=0))
    {
        int flag=1;
        int sum=1;
        for(int i=0;i<n;i++)
        {
            cin>>x>>y;
            if(y>d)
            {
                flag=0;
                continue;
            }
            a[i].left=x-sqrt(d*d-y*y);
            a[i].right=x+sqrt(d*d-y*y);
        }
        if(!flag)
        printf("Case %d: -1\n",Case++);
        else
        {
            sort(a,a+n,cmp);
            double t;
            t=a[0].right;
            for(int i=1;i<n;i++)//判断是否有重叠部分
            {
                if(a[i].left<=t)//有
                {
                    if(a[i].right<t)//比较右交点,找区间更小的
                    t=a[i].right;
                }
                else//没有
                {
                    t=a[i].right;
                    sum++;//雷达加一
                }
            }
            printf("Case %d: %d\n",Case++,sum);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值