贪心-D

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

  • Line 1: Two space-separated integers: N and L

  • Lines 2…N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.

Output

  • Line 1: The miminum number of planks FJ needs to use.

Sample Input

3 3
1 6
13 17
8 12

Sample Output

5

Hint

INPUT DETAILS:

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17.

OUTPUT DETAILS:

FJ can cover the mud pools with five planks of length 3 in the following way:
111222…333444555…

.MMMMM…MMMM.MMMM…

012345678901234567890

题的意思是现在因为暴风雪使地面形成了长度不一的n个泥坑,现用长度为l的木板覆盖这些泥坑,输入n组数据,每组有两个数据,表示泥坑的起始位置和结束位置,求最少需要多少木板。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct pool
{
    int l;
    int r;
}a[10000];
bool cmp(pool a,pool b)
{
    if(a.l=b.l)
    return a.r<b.r;
    else
    return a.l<b.l;
}
int main()
{
    int n,l;
    int sum=0;
    int length=0;
    cin>>n>>l;
    for(int i=0;i<n;i++)
    cin>>a[i].l>>a[i].r;
    sort(a,a+n,cmp);
    for(int i=0;i<n;i++)
    {
        if(length>=a[i].r)//若当前长度大于泥坑的末端,则上一块木板可以铺完
        continue;
        else
        length=max(a[i].l,length);//否则比较当前长度和下一个泥坑的初始长度
        while(length<a[i].r)//铺完当前泥坑
        {
            sum++;
            length+=l;
        }
    }
    cout<<sum<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值