贪心-D

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

  • Line 1: Two space-separated integers: N and L

  • Lines 2…N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.

Output

  • Line 1: The miminum number of planks FJ needs to use.

Sample Input

3 3
1 6
13 17
8 12

Sample Output

5

Hint

INPUT DETAILS:

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17.

OUTPUT DETAILS:

FJ can cover the mud pools with five planks of length 3 in the following way:
111222…333444555…

.MMMMM…MMMM.MMMM…

012345678901234567890

题的意思是现在因为暴风雪使地面形成了长度不一的n个泥坑,现用长度为l的木板覆盖这些泥坑,输入n组数据,每组有两个数据,表示泥坑的起始位置和结束位置,求最少需要多少木板。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct pool
{
    int l;
    int r;
}a[10000];
bool cmp(pool a,pool b)
{
    if(a.l=b.l)
    return a.r<b.r;
    else
    return a.l<b.l;
}
int main()
{
    int n,l;
    int sum=0;
    int length=0;
    cin>>n>>l;
    for(int i=0;i<n;i++)
    cin>>a[i].l>>a[i].r;
    sort(a,a+n,cmp);
    for(int i=0;i<n;i++)
    {
        if(length>=a[i].r)//若当前长度大于泥坑的末端,则上一块木板可以铺完
        continue;
        else
        length=max(a[i].l,length);//否则比较当前长度和下一个泥坑的初始长度
        while(length<a[i].r)//铺完当前泥坑
        {
            sum++;
            length+=l;
        }
    }
    cout<<sum<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以为您介绍一下贪心算法在装船问题上的应用。 装船问题是一个典型的贪心算法应用。题意为:给定一个数组 weights,其中 weights[i] 表示第 i 个物品的重量;另外给定一个正整数 D,表示船的载重量。现在需要将所有物品装到船上,且每个物品必须被装进船里。问最少需要多少艘船才能完成任务。 贪心策略为:每次尽可能地装满一艘船。具体实现过程为: 1. 将物品按照重量从小到大排序。 2. 从左右两端分别取物品,尽可能地让它们的重量相加不超过 D。 3. 如果两个物品的重量之和超过了 D,那么只能将较重的物品装入一艘船,另一艘船再单独装。 4. 重复以上过程,直到所有物品被装入船中。 下面是一个示例代码: ```c++ #include <iostream> #include <vector> #include <algorithm> using namespace std; int findMinBoats(vector<int>& weights, int D) { sort(weights.begin(), weights.end()); // 按照重量从小到大排序 int left = 0, right = weights.size() - 1; int boats = 0; while(left <= right) { if(weights[left] + weights[right] <= D) { // 尽可能地让两个物品的重量相加不超过 D left++; right--; } else { // 如果两个物品的重量之和超过了 D,那么只能将较重的物品装入一艘船,另一艘船再单独装 right--; } boats++; // 每次运载完成后船数加 1 } return boats; } int main() { vector<int> weights = {1, 3, 2, 2, 1}; int D = 3; int minBoats = findMinBoats(weights, D); cout << minBoats << endl; // 输出最少需要的船数 return 0; } ``` 输出结果为:3,表示最少需要三艘船才能完成任务。 希望能帮到您!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值