1004 Counting Leaves

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.
Sample Input

2 1
01 1 02

Sample Output

0 1

题目大意:一个家族族谱,n表示这张图里有多少家庭成员,m表示有m个成员有孩子(非叶节点)。祖宗的ID永远是01,要求输出每层(即每一代)没有孩子的成员数量(每层叶节点的数量)。
思路:深度优先搜索(DFS)。我使用结构体数组保存每个节点的信息,数组下标为成员的ID,便于检索,每个元素包含子节点数量,子节点编号,定义result数组保存每层叶节点的数量。搜索的截止条件为当前节点为叶节点(没有孩子),循环访问节点的每个孩子即可。
代码如下:

#include<iostream>
using namespace std;
int result[110],record;//每层节点,记录最大层
struct node//每个节点的信息
{
  int k;//子节点数量
  int a[110];//子节点编号
}nonlevel[110];//数组下标为编号
void dfs(int id,int level)//编号,所在层
{
  if(!nonlevel[id].k)//没有子节点
  {
    if(level>record)record=level;//更新最大层
    result[level]+=1;//该层叶节点数量+1
    return ;
  }
  for(int i=0;i<nonlevel[id].k;i++)//遍历该点所有的子节点
      dfs(nonlevel[id].a[i],level+1);//继续搜索子节点的子节点
}
int main()
{
  int n,m;
  cin>>n>>m;
  while(m--)//非叶节点
  {
    int k,id;
    cin>>id>>k;
    nonlevel[id].k=k;
    for(int i=0;i<k;i++)//输入节点信息
    {
      int id1;
      cin>>id1;
      nonlevel[id].a[i]=id1;
    }
  }
  dfs(1,1);
  for(int i=1;i<record;i++)cout<<result[i]<<' ';//输出每层叶节点
  cout<<result[record]<<endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值