PAT 甲级 1090  Highest Price in Supply Chain

1090 Highest Price in Supply Chain (25 point(s))

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

经验总结:

emmmmm,把这一题想得太简单,起初我想从叶结点向上直至根结点,记录此路径深度,然后依次访问所有叶结点,但是最后一个测试点超时了,看了一下参考解法,采用的是从上至下,所以猜测最后一个测试点估计路径上的重复结点较多,因此自下而上就做了许多无用功,浪费了时间,总的来说这题是不难的,不过是我想讨巧然后被Judger被嘲讽了= =

AC代码

#include <cstdio>
#include <cmath>
#include <vector>
using namespace std;
const int maxn=100010;
int n,t,root,maxdeep=-1,num=1;
vector<int> child[maxn];
double p,r;

void DFS(int s,int deep)
{
	if(child[s].size()==0)
	{
		if(deep>maxdeep)
		{
			maxdeep=deep;
			num=1;
		}
		else if(deep==maxdeep)
			++num;
		return ;
	}
	for(int i=0;i<child[s].size();++i)
		DFS(child[s][i],deep+1);
}
int main()
{
	scanf("%d %lf %lf",&n,&p,&r);
	r/=100;
	for(int i=0;i<n;++i)
	{
		scanf("%d",&t);
		if(t!=-1)
			child[t].push_back(i);
		else
			root=i;
	}
	DFS(root,0);
	printf("%.2f %d\n",p*pow(1+r,maxdeep),num);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值