PAT 甲级 1105  Spiral Matrix

1105 Spiral Matrix (25 point(s))

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

经验总结:

emmmm  这一题做了这是第三遍了,已经可以独立的写出来了,也是不容易= =、、 这一题弄懂了原理,就很简单,注意只有一个数的特判(不特判第三个测试点会无法通过),以及缩小方块直至方块为1时候的特殊处理(不处理会有测试点超时),就这么多啦~

AC代码

#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=10010;
int n,m,N,d[maxn],spiral[maxn][maxn];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	scanf("%d",&N);
	for(int i=0;i<N;++i)
		scanf("%d",&d[i]);
	sort(d,d+N,cmp);
	if(N==1)
		printf("%d",d[0]);
	else
	{
		n=(int)sqrt(N*1.0);
		while(N%n!=0)
			--n;
		m=N/n;
		int U=0,L=0,R=n-1,D=m-1,num=0,i=0,j=0;
		while(num<N)
		{
			while(j<R&&num<N)
			{
				spiral[i][j]=d[num++];
				++j;
			}
			while(i<D&&num<N)
			{
				spiral[i][j]=d[num++];
				++i;
			}
			while(j>L&&num<N)
			{
				spiral[i][j]=d[num++];
				--j;
			}
			while(i>U&&num<N)
			{
				spiral[i][j]=d[num++];
				--i;
			}
			++i;++j;
			++U;++L;--R;--D;
			if(num==N-1)
			{
				spiral[i][j]=d[num];
				break;
			}
		}
		for(int i=0;i<m;++i)
			for(int j=0;j<n;++j)
				printf("%d%c",spiral[i][j],j<n-1?' ':'\n');
	}
	return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值