1105. Spiral Matrix

1105. Spiral Matrix (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
先找出符合题意的行和列并且对一维数组排序,然后按照顺序访问二维数组,这个过程类似于状态机,可以用判断或选择语句,最后输出二维数组。
#include<iostream>
#include<cmath>
#include<algorithm>

using namespace std;

int m,n,N;
int a[10001];
int ans[101][101];

bool cmp(int x,int y)
{
	return x>y;
}

void findmn()
{
	int mt=N,nt=1;
	for(int i=1;i<=sqrt(double(N));i++)
		for(int j=i;j*i<=N;j++)
			if(j*i==N&&j-i<mt-nt)
			{
				mt=j;
				nt=i;
			}
	m=mt;n=nt;
}

int main()
{
	cin>>N;
	for(int i=1;i<=N;i++)
		cin>>a[i];
	sort(a+1,a+N+1,cmp);
	findmn();

	int u=1,d=m,l=1,r=n;
	int i=1,j=1;
	int state=1;//1 right,2 down,3 left,4 up
	int cnt=1;
	while(cnt<=N)
	{
		if(state==1)
		{
			ans[i][j]=a[cnt];
			if(j==r)
			{
				state=2;
				u++;
				i++;
			}
			else
				j++;
		}
		else if(state==2)
		{
			ans[i][j]=a[cnt];
			if(i==d)
			{
				state=3;
				r--;
				j--;
			}
			else
				i++;
		}
		else if(state==3)
		{
			ans[i][j]=a[cnt];
			if(j==l)
			{
				state=4;
				i--;
				d--;
			}
			else
				j--;
		}
		else
		{
			ans[i][j]=a[cnt];
			if(i==u)
			{
				state=1;
				j++;
				l++;
			}
			else
				i--;
		}
		cnt++;
	}
	for(int i=1;i<=m;i++)
	{
		for(int j=1;j<n;j++)
			cout<<ans[i][j]<<" ";
		cout<<ans[i][n]<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值