HDU 1042.N!【高精度乘法】【8月24】

N!

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
高精度乘法,数组存,每一位存5位数,不然会严重超时。另外,这道题的限制时间为5s(java10s)。代码如下:

#include<cstdio>
int main(){
    int n,m,t;
    while(scanf("%d",&n)==1){
        int f[8005]={0};
        f[0]=1;t=0;
        for(int i=2;i<=n;i++)
        for(int j=0;j<8005;j++){
            f[j]=f[j]*i+t;
            t=f[j]/100000;
            f[j]%=100000;
        }
        for(int i=8004;i>=0;i--)
        if(f[i]){//前面的0不用输出
            m=i;
            printf("%d",f[i]);
            break;
        }
        for(int i=m-1;i>=0;i--)
            printf("%05d",f[i]);//把0也要补起来
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值