POJ 2481.Cows【树状数组】【5月10】

Cows
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 15943 Accepted: 5308

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0
有N个区间,求包含当前区间的区间个数:

思路:

将区间按照右端点从大到小排序,比较左端点,树状数组保存,不断维护树状数组:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 100005;
struct ss
{
    int x, y, id;
}cows[MAX];
bool cmp(ss a, ss b)
{
    if(a.y > b.y) return true;
    else if(a.y == b.y && a.x < b.x) return true;
    else return false;
}
int N, maxn, xi, yi, tree[MAX], ans[MAX];
void Insert(int pos)
{
    while(pos <= maxn+1)
    {
        tree[pos] ++;
        pos += pos&(-pos);
    }
}
int Query(int pos)
{
    int sum = 0;
    while(pos > 0)
    {
        sum += tree[pos];
        pos -= pos&(-pos);
    }
    return sum;
}
int main()
{
    while(scanf("%d", &N) != EOF && N)
    {
        maxn = -1;
        memset(ans, 0, sizeof(ans));
        memset(tree, 0, sizeof(tree));
        for(int i = 0;i < N; ++i)
        {
            scanf("%d %d", &xi, &yi);
            cows[i].x = xi+1;
            cows[i].y = yi+1;
            cows[i].id = i+1;
            if(maxn < cows[i].y) maxn = cows[i].y;
        }
        sort(cows, cows+N, cmp);
        Insert(cows[0].x);
        for(int i = 1;i < N; ++i)
        {
            if(cows[i].x == cows[i-1].x && cows[i].y == cows[i-1].y) ans[cows[i].id] = ans[cows[i-1].id];
            else ans[cows[i].id] = Query(cows[i].x);
            Insert(cows[i].x);
        }
        for(int i = 1;i <= N; ++i)
        {
            if(i != 1) cout <<" ";
            cout << ans[i];
        }
        cout << endl;
    }
    return 0;
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。、可私 6信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 、可私信6博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 、可私信6博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值