HDU 1260  Tickets

 

                                    Tickets

                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                         Total Submission(s): 7736    Accepted Submission(s): 3932


 

Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 

Sample Input

2 2 20 25 40 1 8

 

Sample Output

08:00:40 am 08:00:08 am

 

 

本题题意:让你求一下一群人买票的最短时间,每个人可以选择单独购票或和他前一个(后一个)一起购票

思路:找dp公式    dp[ i ] = min ( dp[ i - 1 ] + a[ i ] , dp[ i - 2 ] + b[ i - 1 ] )  其中a[ i ]为第 i 个人单独买票的时间,b[ i - 1 ] 为第i - 1 个人和第 i 个人一起买票的时间

 

AC代码:

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
typedef long long ll;

ll a[2000+10], dp[2000+10], b[2000+10];

int main()
{
    int k, n;
    scanf("%d", &n);
    while(n--)
    {
        scanf("%d", &k);
        for(int i = 0; i < k; i++)
        {
            scanf("%d", &a[i]);
        }
        for(int i = 0; i < k - 1; i++)
        {
            scanf("%d", &b[i]);
        }
//预处理一下dp[0],dp[1]
        dp[0] = a[0], dp[1] = min(dp[0] + a[1], b[0]);
        for(int i = 2; i < k; i++)
        {
            dp[i] = min(dp[i - 1] + a[i], dp[i -2] + b[i - 1]);
        }
        ll ans1 = (dp[k - 1] / 3600 + 8) % 24;//对不对24取余都没有影响
        ll ans2 = (dp[k - 1] / 60) % 60;
        ll ans3 = dp[k - 1] % 60;
        if(ans1 > 12)
            printf("%02lld:%02lld:%02lld pm\n", ans1 % 12, ans2, ans3);
        else
            printf("%02lld:%02lld:%02lld am\n", ans1, ans2, ans3);
    }
    return 0;
}

 

 

 

个人感觉这题考的是输出格式,自己就在输出格式上WA过一次。。。。。。。。。。

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值