HDU 2114 Calculate S(n) (公式)

Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output
For each case, output the last four dights of S(N) in one line.

Sample Input
  
  
1 2

Sample Output
  
  
0001 0009
题意很明显:
有公式:

1^3 + 2^3 + …… n^3 = [n (n+1) / 2]^2=(1+2+……+n)^2

AC:
#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        n=n%10000;
        n=(n*(n+1)/2)%10000;
        n=(n*n)%10000;
        printf("%04d\n",n);
    }
    return 0;
}
/*超时代码。
#include<stdio.h>
int main()
{
    int n,i,x,xx;
    int sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        for(i=1;i<=n;i++)
        {
            x=i%10000;
            xx=x;
            x=(x*x)%10000;
            sum=sum+(x*xx)%10000;
            if(sum>=10000)
            sum=sum%10000;
        }
        printf("%04d\n",sum);
    }
    return 0;
}
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值