libpng与zlib的坑

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/aa1600159112/article/details/76664566

错误信息

root@iZ94hbx8k2tZ:/usr/local/php/libpng-1.6.30# make && make install
make all-am
make[1]: Entering directory /usr/local/php/libpng-1.6.30'
/bin/bash ./libtool --tag=CC --mode=link gcc -g -O2 -o pngfix contrib/tools/pngfix.o libpng16.la -lm -lz -lm
libtool: link: gcc -g -O2 -o .libs/pngfix contrib/tools/pngfix.o ./.libs/libpng16.so -lz -lm
./.libs/libpng16.so: undefined reference to
inflateValidate’
collect2: error: ld returned 1 exit status
make[1]: * [pngfix] Error 1
make[1]: Leaving directory `/usr/local/php/libpng-1.6.30’
make: * [all] Error 2

安装libpng时遇到上面的错误,刚开始我以为是什么动态库没有自动加载的问题,下载了最新的zlib和libpng包,先装zlib然后装libpng。然而,这里有个坑,zlib.1.2.11版本跟libpng-1.6.31版本不能正常匹配,亲测,libpng-1.6.30与zlib.1.2.11也不行
现在可行的是也是我目前知道能行的是:zlib-1.2.8与libpng-1.6.21
wget https://sourceforge.net/projects/libpng/files/zlib/1.2.8/zlib-1.2.8.tar.gz
wget ftp://ftp.simplesystems.org/pub/libpng/png/src/libpng16/libpng-1.6.21.tar.gz

没有更多推荐了,返回首页