poj2676(Sudoku)

/**

  

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

Source

**/

#include <iostream>
#define clear(array) memset(array,false,sizeof(array))
using namespace std;

bool Row[9][10]; //用于标识第i行用到了1-9中的哪些数。R[i][j] = true表示第i行数j已经使用过了
bool Column[9][10]; //用于标识第i列用到了1-9中的哪些数。说明同上
bool Block[9][10]; //用于标识每一个3*3列的方块中用到了1-9中的哪些数
//bool Tag[9][9];
int A[9][9]; //存储输入数据


void init()
{
 clear(Row);  //初始化数组,下同
 clear(Column);
 clear(Block);
 //clear(Tag);
 memset(A,0,sizeof(A));
}
void input()
{
 int temp = 0;
 
 for (int i=0; i<9; ++i)
 {
  for (int j=0; j<9; ++j)
  {
   scanf("%1d",&temp);
   if (temp) //如果输入不为0
   {
    A[i][j] = temp;
    Row[i][temp] = true;
    Column[j][temp] = true;
    Block[3*(i/3)+j/3][temp] = true;
   }
  }
 }
 cout << endl;
}

bool sudoku(int n)
{
 int i = n / 9; //9*9中数组的行号
 int j = n % 9; //列号

 if (n > 80)  return true; //搜索到最后一个节点返回
 if (!A[i][j])
 {
  for (int k=1; k<=9; ++k)
  {
   if (!Row[i][k] && !Column[j][k] && !Block[3*(i/3)+j/3][k])//k可以放在当前位置
   {
    A[i][j] = k;
    Row[i][k] = true;
    Column[j][k] = true;
    Block[3*(i/3)+j/3][k] = true;

    if (sudoku(n+1)) return true; //搜索解决下一个位置

    A[i][j] = 0;
    Row[i][k] = false;
    Column[j][k] = false;
    Block[3*(i/3)+j/3][k] = false;

   }
  }
  return false; //此处的return 很重要。切记:回溯递归时正确return很重要。一个if一个return
 }
 if (sudoku(n+1)) return true;
 
 return false;
}

void output()
{
 for (int i=0; i<9; ++i)
 {
  for (int j=0; j<9; ++j)
  {
   cout << A[i][j];
  }
  cout << endl;
 }
}

int main()
{
 int n = 0;
 cin >> n;

 for (int i=0; i<n; ++i)
 {
  init();
  input();
  sudoku(0);
  output();
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4S店客户管理小程序-毕业设计,基于微信小程序+SSM+MySql开发,源码+数据库+论文答辩+毕业论文+视频演示 社会的发展和科学技术的进步,互联网技术越来越受欢迎。手机也逐渐受到广大人民群众的喜爱,也逐渐进入了每个用户的使用。手机具有便利性,速度快,效率高,成本低等优点。 因此,构建符合自己要求的操作系统是非常有意义的。 本文从管理员、用户的功能要求出发,4S店客户管理系统中的功能模块主要是实现管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理,用户客户端:首页、车展、新闻头条、我的。门店客户端:首页、车展、新闻头条、我的经过认真细致的研究,精心准备和规划,最后测试成功,系统可以正常使用。分析功能调整与4S店客户管理系统实现的实际需求相结合,讨论了微信开发者技术与后台结合java语言和MySQL数据库开发4S店客户管理系统的使用。 关键字:4S店客户管理系统小程序 微信开发者 Java技术 MySQL数据库 软件的功能: 1、开发实现4S店客户管理系统的整个系统程序; 2、管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理等。 3、用户客户端:首页、车展、新闻头条、我的 4、门店客户端:首页、车展、新闻头条、我的等相应操作; 5、基础数据管理:实现系统基本信息的添加、修改及删除等操作,并且根据需求进行交流信息的查看及回复相应操作。
现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本微信小程序医院挂号预约系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此微信小程序医院挂号预约系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。微信小程序医院挂号预约系统有管理员,用户两个角色。管理员功能有个人中心,用户管理,医生信息管理,医院信息管理,科室信息管理,预约信息管理,预约取消管理,留言板,系统管理。微信小程序用户可以注册登录,查看医院信息,查看医生信息,查看公告资讯,在科室信息里面进行预约,也可以取消预约。微信小程序医院挂号预约系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值