hdu 6024 Building Shops

Building Shops

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2659    Accepted Submission(s): 911


Problem Description
HDU’s  n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these  n classrooms.

The total cost consists of two parts. Building a candy shop at classroom  i would have some cost  ci. For every classroom  P without any candy shop, then the distance between  P and the rightmost classroom with a candy shop on  P's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
 

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer  n(1n3000), denoting the number of the classrooms.
In the following  n lines, each line contains two integers  xi,ci(109xi,ci109), denoting the coordinate of the  i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
 

Output
For each test case, print a single line containing an integer, denoting the minimal cost.
 

Sample Input
 
 
3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1
 

Sample Output
 
 
5 11
 

Source
 

Recommend
jiangzijing2015
 

Statistic |  Submit |  Discuss |  Note


这题一看就是一个动态规划题,题目意思为你有n个教室,要满足以下的情况

1如果当前教室要造糖果点,费用要加上该店的费用

2如果当前教室不造糖果点,则费用为它到它左端最近糖果点的路程差(第一个教室一定有糖果点)


二维dp,dp[i][j],i代表classroom数量,j代表下标最大糖果点的位置

还有一点,数据不是按照x坐标升序给出的,也就是说要先对x排序,我没排序wa了2-3次,还以为是其他问题


#include<cstdio>
#include<algorithm>
using namespace std;
long long dp[3005][3005];
struct me{
    long long s,v;
}my[3005];
bool cmp(struct me a,struct me b){
    return a.s<b.s;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++)
            scanf("%lld%lld",&my[i].s,&my[i].v);
        sort(1+my,my+1+n,cmp);
        dp[1][1]=my[1].v;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<i;j++)
                dp[i][j] = dp[i-1][j] + my[i].s - my[j].s;
            dp[i][i] = 1e18;
            for(int j=1;j<i;j++)
                dp[i][i] = min(dp[i][i], dp[i-1][j]+my[i].v);
        }
        long long mmax=1e18;
        for(int i=1;i<=n;i++)
            mmax=min(mmax,dp[n][i]);
        printf("%lld\n",mmax);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值