Building Shops HDU - 6024

Building Shops

  HDU - 6024

HDU’s  nn classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these  nn classrooms. 

The total cost consists of two parts. Building a candy shop at classroom  ii would have some cost  cici. For every classroom  PP without any candy shop, then the distance between  PP and the rightmost classroom with a candy shop on  PP's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side. 

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him. 
InputThe input contains several test cases, no more than 10 test cases. 
In each test case, the first line contains an integer  n(1n3000)n(1≤n≤3000), denoting the number of the classrooms. 
In the following  nn lines, each line contains two integers  xi,ci(109xi,ci109)xi,ci(−109≤xi,ci≤109), denoting the coordinate of the  ii-th classroom and the cost of building a candy shop in it. 
There are no two classrooms having same coordinate.OutputFor each test case, print a single line containing an integer, denoting the minimal cost.Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5
11

题意:按教室位置从左到右建糖果屋, 如果建糖果屋花销为建设费用, 如果不建则花销为 当前教室位置与左侧第一个糖果屋位置之差, 此外,第一个教室必须建为糖果屋。

思路:这个点有两种可能  建糖果店  不建糖果店 所以是道dp题

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 3010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;

struct node
{
    LL x,c;  //x是位置,c是权值
};
bool cmp(node a,node b)
{
    return a.x<b.x;
}
node a[maxn];
LL f[maxn][maxn];
LL dp[maxn][2];
int n;
int main()
{
    while(scanf("%d",&n)!=EOF){
        memset(dp,0,sizeof(dp));
        memset(f,0,sizeof(f));
        for(int i=0;i<n;i++){
            scanf("%lld%lld",&a[i].x,&a[i].c);
        }
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++){         //预处理不建糖果屋的情况,f存储的是距离
            for(int j=i+1;j<n;j++){
                f[i][j]=f[i][j-1]+a[j].x-a[i].x;
            }
        }
        dp[0][0]=dp[0][1]=a[0].c;     //dp[][0]:此点不建糖果屋,dp[][1]:此点建糖果屋
        for(int i=1;i<n;i++){
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+a[i].c;
            dp[i][0]=dp[0][1]+f[0][i];
            for(int j=1;j<=i-1;j++){
                dp[i][0]=min(dp[i][0],dp[j][1]+f[j][i]);
            }
        }
        printf("%lld\n",min(dp[n-1][0],dp[n-1][1]));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值