HDU - 6024 Building Shops

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3264    Accepted Submission(s): 1119

题目描述:

Problem Description

HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.

Input

The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.

Output

For each test case, print a single line containing an integer, denoting the minimal cost.

Sample Input

3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1

Sample Output

5 11


dp,我们将dp[i][0]表示为第i个不建的最小花费,dp[i][1]表示第i个建的最小花费,易得到

dp[i][1] = min(dp[i - 1][0], dp[i - 1][1]) + ci;

而dp[i][0]的求法为选取dp[1 ... i - 1][1]的每一种情况(设选取的教室为j),算出dp[j][1] + (从j + 1到i这其中每一处到j处的距离之和),这样的i - 1种情况中最小的即为dp[i][0]的值。注意计算(从j + 1到i每一处到j处的距离之和)时需要处理成常数级时间。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>

#define ll long long
using namespace std;

const int maxn = 3e3 + 6;
const ll INF = 0x3f3f3f3f3f3f3f3f;

ll dp[maxn][2];

struct node
{
    ll x, c;
}classr[maxn];

bool cmp(node a, node b)
{
    return a.x < b.x;
}

int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        for(int i = 1; i <= n; i++)
            scanf("%lld%lld", &classr[i].x, &classr[i].c);
        stable_sort(classr + 1, classr + n + 1, cmp);
        for(int i = 1; i <= n; i++)
            dp[i][0] = dp[i][1] = INF;
        dp[1][0] = dp[1][1] = classr[1].c;
        for(int i = 2; i <= n; i++)
        {
            dp[i][1] = min(dp[i - 1][0], dp[i - 1][1]) + classr[i].c;
            ll sum = 0;
            for(int j = i - 1; j >= 1; j--)
            {
                sum += (i - j) * (classr[j + 1].x - classr[j].x);
                dp[i][0] = min(dp[i][0], dp[j][1] + sum);
            }
        }
        printf("%lld\n", min(dp[n][0], dp[n][1]));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值