1729二分法判断

二分法判断

Time Limit: 1 Seconds     Memory Limit: 32768 K

Total Submit:305     Accepted:227


Description

给定一组由小到大的整数{1, 3, 4, 5, 6, 7, 10, 13, 22, 23, 30, 32, 33, 34, 36} ,再任给一整数x0,用二分法判断x0是否在该数组之中,如果在输出true,否则输出false

Input

x0

Output

如果x0在数组中,输出true,否则输出false (并换行回车)

Sample Input

9 

 

Sample Output

false

Source:

#include<iostream.h>
int count(int a[],int low,int high,int n)
{
	if(low>high)
		return 0;
	else
	{
		int mid=(low+high)/2;
		if(a[mid]>n)
			return count(a,low,mid-1,n);
		else if(a[mid]<n)
			return count(a,mid+1,high,n);
		else
			return 1;
	}
}

int main()
{
 int a[16]={1, 3, 4, 5, 6, 7, 10, 13, 22, 23, 30, 32, 33, 34, 36},x0;
cin>>x0;

if(count(a,0,15,x0))
cout<<"true"<<endl;
else
cout<<"false"<<endl;


	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值