1006.Sign in and Sign out(25)—PAT 甲级

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:在一堆开门关门的员工中,分别找到最早开门和最晚关门的员工号.
分析:利用c++string类型用字典序进行比较的特性直接比较开门时间和关门时间,temp_unlock和temp_lock分别是比较开门时间和关门时间的临时变量,first_unlock和last_lock分别用来记录最早开门和最晚开门的员工号。

#include <iostream>
using namespace std;
int main() {
    string first_unlock,final_lock;
    int m;
    scanf("%d",&m);
    string id_number,unlock,lock;
    string temp_unlock="9",temp_lock="0";
    for(int i=0;i<m;i++)
    {
        cin>>id_number>>unlock>>lock;
        if(unlock<temp_unlock){
            temp_unlock=unlock;
            first_unlock=id_number;
        }
        if(lock>temp_lock){
            temp_lock=lock;
            final_lock=id_number;
        }
    }
    cout<<first_unlock<<" "<<final_lock<<endl;
    return 0;
}

转载于:https://www.cnblogs.com/Endlessp162096/p/8971944.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值