【PAT B1015】 德才论 (25 分)

宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

输入格式:

输入第一行给出 3 个正整数,分别为:N(≤10​5​​),即考生总数;L(≥60),为录取最低分数线,即德分和才分均不低于 L 的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于 H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线 L 的考生也按总分排序,但排在第三类考生之后。

随后 N 行,每行给出一位考生的信息,包括:准考证号 德分 才分,其中准考证号为 8 位整数,德才分为区间 [0, 100] 内的整数。数字间以空格分隔。

输出格式:

输出第一行首先给出达到最低分数线的考生人数 M,随后 M 行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

输入样例:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

输出样例:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

 

思路:

  开始想的很简单,就是sort排序,然后考虑到要给考生分类,那么就多定义几个结构体数组来存储,最后再按每一类来排序,输出。虽然代码很重复,还是pass了~~

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;

struct Student{
	int sno;
	int d_score;
	int c_score;
	//int sum=d_score+c_score;
}stu[100010],stu1[100010],stu2[100010],stu3[100010],stu4[100010];

bool cmp(Student a,Student b){
	int sumA=a.d_score+a.c_score;
	int sumB=b.d_score+b.c_score;
	if(sumA!=sumB)
		return sumA>sumB; //从高到低排序 
	else{
		if(a.d_score==b.d_score) return a.sno<b.sno;
		return a.d_score>b.d_score;
	}
}

int main(){
	int N,L,H;
	scanf("%d%d%d",&N,&L,&H);
	for(int i=0;i<N;i++)
		scanf("%d%d%d",&stu[i].sno,&stu[i].d_score,&stu[i].c_score);
	
	int r=0,s=0,t=0,u=0;
	for(int i=0;i<N;i++){
		if(stu[i].d_score>=L&&stu[i].c_score>=L){ //德才分都要>最低录取线L
		
			if(stu[i].d_score>=H&&stu[i].c_score>=H){
				//一类 才德全尽
				stu1[++r]=stu[i];
			}
			
			else if(stu[i].c_score<H&&stu[i].d_score>=H){
				//二类 德胜才
				stu2[++s]=stu[i];
			}
		
			else if(stu[i].c_score<H&&stu[i].d_score<H&&stu[i].d_score>=stu[i].c_score){
				//三类 才德兼亡 但尚有 德胜才
				stu3[++t]=stu[i];
			}
			
			else{
				stu4[++u]=stu[i];
			} 	
		}		
	}
	
	sort(stu1+1,stu1+r+1,cmp);  //第一个stu1是stu1[1]
	sort(stu2+1,stu2+s+1,cmp);
	sort(stu3+1,stu3+t+1,cmp);
	sort(stu4+1,stu4+u+1,cmp);
	
	printf("%d\n",r+s+t+u);
	
	for(int i=1;i<=r;i++)  
		printf("%d %d %d\n",stu1[i].sno,stu1[i].d_score,stu1[i].c_score);
	
	for(int i=1;i<=s;i++)
		printf("%d %d %d\n",stu2[i].sno,stu2[i].d_score,stu2[i].c_score);
	
	for(int i=1;i<=t;i++)
		printf("%d %d %d\n",stu3[i].sno,stu3[i].d_score,stu3[i].c_score);
		
	for(int i=1;i<=u;i++)
		printf("%d %d %d\n",stu4[i].sno,stu4[i].d_score,stu4[i].c_score);
}

 

然后,进一步考虑,可以在cmp函数上做文章。在stu结构体上添加clas字段区分不同类别的考生,然后在cmp函数里面通过对类别、总分、德分、学号几个字段依次比较,就可以满足对这些考生进行排序了~

其中有一点要注意,因为对类别由一等往后推,若不考虑不合格学生,他们的类别可能默认为0,就排在最前面了,所以在循环体里面也要对他们判断,给类别往后排。

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;

struct Student{
	int sno;  //准考证号 
	int d_score;  //德分 
	int c_score;  //才分 
	int sum; //德才总分 
	int clas; //考生类别 
}stu[100010];

bool cmp(Student a,Student b){
	if(a.clas!=b.clas)  return a.clas<b.clas;  //按考生类别 从一等往后排 
	else if(a.sum!=b.sum)  return a.sum>b.sum;  //类别相同,则按学生总分从高到低 
	else if(a.d_score!=b.d_score)  return a.d_score>b.d_score;  //若总分也相同,则按 德分 从高到低 
	else return a.sno<b.sno;  //若以上都相同,则按学号从前到后排 
}

int main(){
	int N,L,H;
	int count=0;
	scanf("%d%d%d",&N,&L,&H);
	for(int i=0;i<N;i++){
		scanf("%d%d%d",&stu[i].sno,&stu[i].d_score,&stu[i].c_score);
		stu[i].sum=stu[i].d_score+stu[i].c_score;
		
		if(stu[i].d_score>=L && stu[i].c_score>=L){
			count++;
			if(stu[i].d_score>=H && stu[i].c_score>=H)  stu[i].clas=1;
			else if(stu[i].d_score>=H&&stu[i].c_score<H)  stu[i].clas=2;
			else if(stu[i].d_score<H&&stu[i].c_score<H&&stu[i].d_score>=stu[i].c_score)  stu[i].clas=3;
			else stu[i].clas=4;		
    	}
    	
    	else stu[i].clas=5;  //一开始,没有考虑这个,有两个测试点没过
	}
	printf("%d\n",count);
	sort(stu,stu+N,cmp);
	for(int i=0;i<count;i++){
		printf("%d %d %d\n",stu[i].sno,stu[i].d_score,stu[i].c_score);
	}
} 
	

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值