POJ 2376 Cleaning Shifts 贪心法

题目:

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T

Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

思考了下午都没思考出来,百度看了一些大佬的还是一知半解,最后瞧见了一份思路超清晰的大佬代码才恍然大悟。
参考大佬超清晰代码:小cc宸

AC代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int n,t;
struct cow{
	int start;
	int end;
};
bool cmp(cow a,cow b){
	if(a.start!=b.start){
		return a.start<b.start;
	}
	else{
		return a.end>b.end;
	}
}
int main(){
	while(cin>>n>>t){
		cow c[n+5];
		for(int i=0;i<n;i++){
			cin>>c[i].start>>c[i].end;
		}
		sort(c,c+n,cmp);//排序
		int st=0;//头 
		int max=0;//最远距离 
		int right=0;//存右区间 
		int ans=0;//次数 
		int i=0;
		while(right<t&&i<n){
			st=right+1;
			ans++;
			if(c[i].start>st){
				break;
			}
			while(c[i].start<=st&&i<n){
				max=c[i].end>max?c[i].end:max;//判断符合条件的最远区间 
				i++;
			}
			right=max;//更新右区间 
		}
		if(right<t){
			cout<<"-1"<<endl;
		}
		else{
			cout<<ans<<endl; 
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值