FZU 2140 Forever 0.5

Problem 2140 Forever 0.5

Problem Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. 

Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input

3
2
3
5

Sample Output

No
No
Yes
0.000000 0.525731
-0.500000 0.162460
-0.309017 -0.425325
0.309017 -0.425325
0.500000 0.162460

Hint

This problem is special judge.



这个是省赛预选赛第一题。。。

第一次做sj的题目

被样例误导憨憨憨地算起来了正多边形每个顶点的位置最后发现除了5边形其他的面积都大于0.75。。。

比赛完后查了一下题解才知道 因为sj嘛 随便搞搞只要符合条件就可以

然后以原点O为圆心以1为半径的圆上的点到原点距离都是1

所以在上面找就可以了

首先三角形要求是等边三角形发现面积小于0.5

然后四边形 为了方便就这样取吧坐标比较好表示


然后在(0.5,sqrt(1-0.25))和(1,0)之间的弧上任取点 到(0,0)的距离都是1 而到其他点的距离都小于1满足题目要求

所以昨天憨狗了

keep it simple & stupid

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double x[111],y[111];
int T,m;
int main()
{
	x[1]=0;y[1]=0;
	x[2]=1;y[2]=0;
	x[3]=0.5;y[3]=(sqrt(1-0.5*0.5));
	x[4]=0.5;y[4]=y[3]-1;
	for(int i=5;i<=100;++i)
	{
		x[i]=0.5+0.004*i;
		y[i]=sqrt(1-x[i]*x[i]);
	}
	cin>>T;
	while(T)
	{
		T--;
		cin>>m;
		if(m<4)cout<<"No"<<endl;
		else
		{
			cout<<"Yes"<<endl;
			for(int j=1;j<=m;++j)
			printf("%.6lf %.6lf\n",x[j],y[j]);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值