Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 9839 | Accepted: 5050 |
Description
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.
Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.
Input
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.
Output
Sample Input
2 2 100 1 100 2 3 1 10 1 11 100 12
Sample Output
330 1344
题意:给你要买的珍珠的类型、数目和价格,求买到高质量珍珠所用的最小价值;
【规定买任一类的珍珠n个(价格为p),都要支付(n+10)*p的钱,即额外支付10*p】
例如样例Input的第二个例子:
3
1 10
1 11
100 12
需要买第一类1个,第二类1个,第三类100个
按常规支付为 (1+10)*10 + (1+10)*11 + (100+10)*12 = 1551元(一共买了102个珍珠)
但是如果全部都按照第三类珍珠的价格支付,同样是买102个,而且其中总体质量还被提高了,但是价格却下降了:(102+10)*12 = 1344元
而对于样例Input的第一个例子:
2
100 1
100 2
按常规支付为 (100+10)*1 + (100+10)*2 =330元
但是全部按第二类珍珠的价格支付,同样买200个,虽然总体质量提升了,但是价格也提高了: (202+10)*2=424元
dp的思路在于,可以用后一种类型的珍珠代替前面的珍珠,从而产生提高珍珠质量,降低所需的价值。
本题关键点在于:
(1) 要求要买的珍珠的数量是一定的
(2) 所买的珍珠的质量允许提高,但不允许下降(即可以用高质量珍珠替代低质量)
(3) 输入时,后输入的珍珠价格一定比前面输入的要贵
(4) 由(2)(3)知,珍珠的替代必须是连续的,不能跳跃替代(这个不难证明,因为假如用第i+2类去替代第i类珍珠,会使最终的支付价格降低,那么用第i+1类去替代第i类珍珠会使最终的支付价格更加低)根据这4个约束条件,那么购买珍珠的方案为:
在珍珠类型的总区间[1,c]中划分多个子区间,其中在闭区间i1~j1的珍珠全部按第j1类珍珠的价格p1支付,在闭区间i2~j2的珍珠全部按第j2类珍珠的价格p2支付,…在闭区间in~jn的珍珠全部按第jn类珍珠的价格pn支付。 这些区间互不相交。
其余珍珠按其原价支付。
要求找出最优的划分方案,使得最终支付价格最低。
令dp[i]表示在已知第i类珍珠时,所需支付的最低价格
则状态方程为:
dp[i]=(a[i]+10)*p[i]+dp[i-1]; //当第i种珍珠出现时,未优化价格的情况
dp[i]=min(dp[i],(sum[i]-sum[j]+10)*p[i]+dp[j]); //枚举j,价格优化
dp[0]=0; //Dp初始化
sum[i] 前缀和,保存珍珠数目ac代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[1005];
int a[1005];
int p[1005];
int sum[1005];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
memset(p,0,sizeof(p));
memset(sum,0,sizeof(sum));
int c;
scanf("%d",&c);
for(int i = 1; i <= c; i++)
{
scanf("%d %d",&a[i],&p[i]);
sum[i] = sum[i-1] + a[i];
}
for(int i = 1; i <= c; i++)
{
dp[i] = dp[i-1] + (a[i]+10)*p[i];//未优化时的价格,此时dp[i-1]已经为最优
for(int j = 0; j < i; j++)
{
dp[i] = min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i]);//对dp[i]进行优化,用第i种珍珠代替第j+1 ~ i种珍珠
}
}
printf("%d\n",dp[c]);
}
return 0;
}