Calculate S(n) (规律题)

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10508    Accepted Submission(s): 3771


Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .
 

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output
For each case, output the last four dights of S(N) in one line.
 

Sample Input
  
  
1 2
 

Sample Output
  
  
0001 0009
 
题意:
给你一个n,问你1^3+2^3+3^3+4^3+...+n^3的后四位是多少。

解析:
就一个公式,(1^3+2^3+3^3+4^3+...+n^3) = (1 + 2 + 3 + 4 + ... + n)^ 2
注意取模就好了。

#include <algorithm>
#include <iostream>
#include <numeric>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <cstdio>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

const int mod = 1e4;
const double esp = 1e-6;
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int maxn = 500005;
using namespace std;

int main(){
    LL n;
    while(cin>>n){
        LL num = (n * (n + 1)) >> 1;
        num %= mod;
        num *= num;
        printf("%04d\n",num%mod);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值