UVA 106 Fermat vs. Pythagoras(数论)

 Fermat vs. Pythagoras 

Background

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level.

This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of tex2html_wrap_inline29 for n > 2.

The Problem

Given a positive integer N, you are to write a program that computes two quantities regarding the solution of

displaymath22

where xy, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x<yz, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values tex2html_wrap_inline51 such that p is not part of any triple (not just relatively prime triples).

The Input

The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file.

The Output

For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is tex2html_wrap_inline57 ). The second number is the number of positive integers tex2html_wrap_inline57 that are not part of any triple whose components are all tex2html_wrap_inline57 . There should be one output line for each input line.

Sample Input

10
25
100

Sample Output

1 4
4 9
16 27
参考了题解 http://www.cnblogs.com/devymex/archive/2010/08/07/1799713.html

这题的关键在于求x,y,z值,,直接遍历O(n3)肯定超时,根据题解推出的公式转换为遍历m, n复杂度为O(n)。

代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
int max(int a, int b) {return a > b ? a : b;}
const int MAXN = 1000005;
int N, n, m, num, x, y, z, vis[MAXN], ans, count;

bool judge(int m, int n) {
	int a = m, b = n;
	if (a < b) {
		int t = b;
		b = a;
		a = t;
	}
	while (b) {
		int t = b;
		b = a % t;
		a = t;
	}
	if (a == 1)
		return true;
	else
		return false;
}
int main() {
	while (~scanf("%d", &N)) {
		ans = count = 0;
		memset(vis, 0, sizeof(vis));
		num = int(sqrt(N));
		for (n = 1; n <= num; n ++)
			for (m = n + 1; m <= num; m ++) {
				x = m * m - n * n;
				y = 2 * m * n;
				z = m * m + n * n;
				if (x <= N && y <= N && z <= N && judge(x, y) && judge(x, z) && judge(z, y)) {
					ans ++;
					int Max = max(x, max(y, z));
					for (int i = 1; Max * i <= N; i ++) {
						vis[x * i] = vis[y * i] = vis[z * i] = 1;
					}
				}
			}
		for (int j = 1; j <= N; j ++) {
			if (!vis[j])
				count ++;
		}
		printf("%d %d\n", ans, count);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值