数据结构实验之二叉树五:层序遍历
Time Limit: 1000MS Memory limit: 65536K
题目描述
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。
输入
输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是
一个长度小于50个字符的字符串。
输出
输出二叉树的层次遍历序列。
示例输入
2 abd,,eg,,,cf,,, xnl,,i,,u,,
示例输出
abcdefg xnuli
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef char telemtype;
typedef char status;
typedef struct BiTNode
{
telemtype data;
struct BiTNode *lchild, *rchild;
}*BiTree;
char c[55];
int i;
status create(BiTree &T)
{
if(c[i++]==',') T=NULL;
else
{
T = (BiTNode *) malloc (sizeof(BiTNode));
if(!T) exit(0);
T->data = c[i-1];
create(T->lchild);
create(T->rchild);
}
return 1;
}
typedef BiTree QElemType;//注意此类型应定义为BiTree
typedef char Status;
typedef struct QNode
{
QElemType data;
QNode *next;
} QNode, *Queueptr;
typedef struct
{
Queueptr front;
Queueptr rear;
} LinkQueue;
Status InitQueue (LinkQueue &Q)
{
Q.front = Q.rear = (Queueptr)malloc(sizeof(QNode));
if (!Q.front) exit (0);
Q.front->next = NULL;
return 1;
}
Status EnQueue (LinkQueue &Q, QElemType e)
{
Queueptr p;
p = (Queueptr) malloc (sizeof (QNode));
if (!p) exit (0);
p->data = e;
p->next = NULL;
Q.rear->next = p;
Q.rear = p;
return 1;
}
Status DeQueue (LinkQueue &Q, QElemType &e)
{
Queueptr p;
if (Q.front == Q.rear)
return 0;
p = Q.front->next;
e = p->data;
Q.front->next = p->next;
if (Q.rear == p)
Q.rear = Q.front;
free (p);
return 1;
}
Status QueueEmpty(LinkQueue Q)
{
if(Q.front==Q.rear)
return 1;
else
return 0;
}
void Traverse(BiTree T)
{
LinkQueue Q;
BiTree p;
p=T;
InitQueue(Q);
if(p)
EnQueue(Q, p);
while(!QueueEmpty(Q))
{
DeQueue(Q, p);
printf("%c", p->data);
if(p->lchild)
EnQueue(Q, p->lchild);
if(p->rchild)
EnQueue(Q, p->rchild);
}
}
int main()
{
BiTree T;
int t;
scanf("%d", &t);
while(t--)
{
scanf("%s", c);
i=0;
create(T);
Traverse(T);
printf("\n");
}
}
#include <bits/stdc++.h>
using namespace std;
typedef char telemtype;
typedef int status;
typedef struct bitnode
{
char data;
bitnode *lchild, *rchild;
}bitnode, *bitree;
char c[55];
int i=0;
void createbitree(bitree &t)
{
char ch = c[i++];
if(ch==',') t=NULL;
else
{
t = (bitnode *)malloc(sizeof(bitnode));
if(!t)
exit(-1);
t->data = ch;
createbitree(t->lchild);
createbitree(t->rchild);
}
}
void Traverse(bitree &t)
{
queue <bitree> q;
bitree p;
p = t;
if(p)
{
q.push(p);
}
while(!q.empty())
{
p = q.front();
q.pop();
printf("%c",p->data);
if(p->lchild)
q.push(p->lchild);
if(p->rchild)
q.push(p->rchild);
}
}
int main()
{
int m;
bitree t;
scanf("%d", &m);
while(m--)
{
i=0;
scanf("%s", c);
createbitree(t);
Traverse(t);
printf("\n");
}
return 0;
}