树结构练习——排序二叉树的中序遍历
Time Limit: 1000MS Memory limit: 65536K
题目描述
在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
输入
输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。
输出
为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
示例输入
1 2 2 1 20
示例输出
2 1 20
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef int status;
typedef struct bitnode
{
int data;
struct bitnode *lchild, *rchild;
}*bitree;
status Insert(bitree &t, int key)//直接插入法 ,若用查找插入法则wrong answer
{
if(t==NULL)//创建一个新的结点
{
t=new bitnode;
t->lchild=NULL;
t->rchild=NULL;
t->data=key;
}
else
{
if(key < t->data)
Insert (t->lchild,key);
else
Insert (t->rchild,key);
}
}
int k;
int mid[1010];//借用mid数组防止PE格式错误
void inorder(bitree &t, int mid[])
{
if(t)
{
inorder(t->lchild, mid);
mid[k++] = t->data;
inorder(t->rchild, mid);
}
}
int main()
{
int n, i, num;
while(~scanf("%d", &n))
{
bitree t1 = NULL;//切记清零, 否则runtime error
for(i=0; i<n; i++)
{
scanf("%d", &num);
Insert(t1, num);
}
k = 0;//一定要在循环内定义
inorder(t1, mid);
for(i=0;i<n-1;i++)
printf("%d ", mid[i]);
printf("%d\n", mid[n-1]);
}
}