Catch That Cow

Catch That Cow

Time Limit: 2000MS Memory limit: 65536K

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4



#include <stdio.h>
#include <stdlib.h>
#include <queue>
#include <string.h>
#define INF 0x3f3f3f3f
#define MAX 200010  //注意MAX取值 否则RE
using namespace std;
struct node
{
    int step;
    int x;
} a, b;

int v[200010];//标记数组
int c(int x)
{
    if(x<0||x>=MAX||v[x])//必须考虑越界的情况否则RE
        return 0;
    return 1;
}

int n, m;
int bfs(int n)
{
    queue<node> q;
    a.x = n;
    a.step = 0;
    v[a.x] = 1;
    q.push(a);
    while(!q.empty())
    {
        a = q.front();
        q.pop();
        if(a.x == m)
            return a.step;
        b = a;
        //每次都将三种状况加入队列之中
        if(c(a.x+1))
        {
            b.x = a.x+1;
            b.step = a.step+1;
            v[a.x+1] = 1;
            q.push(b);
        }
        if(c(a.x-1))
        {
            b.x = a.x-1;
            b.step = a.step+1;
            v[a.x-1] = 1;
            q.push(b);
        }
        if(c(a.x*2))
        {
            b.x = a.x*2;
            b.step = a.step+1;
            v[a.x*2] = 1;
            q.push(b);
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d %d", &n, &m))
    {
        memset(v, 0, sizeof(v));

        printf("%d\n", bfs(n));
    }

    return 0;
}


#include <stdio.h>
#include <stdlib.h>
#include <queue>
#include <string.h>
using namespace std;
int n, m;
int v[200010];
struct node
{
    int x;
    int step;
}a, b, c;
int bfs(int k)
{
    int i, j;
    memset(v, 0, sizeof(v));
    queue<node> q;
    a.x = k;
    a.step = 0;
    q.push(a);
    v[k] = 1;
    while(!q.empty())
    {
        a = q.front();
        q.pop();
        if(a.x == m)
            return a.step;
        if(!v[a.x-1]&&a.x-1>=0&&a.x-1<=100000)
        {
            b.x = a.x-1;
            v[b.x] = 1;
            b.step = a.step+1;
            q.push(b);
        }
        if(!v[a.x+1]&&a.x+1>=0&&a.x+1<=100000)
        {
            b.x = a.x+1;
            v[b.x] = 1;
            b.step = a.step+1;
            q.push(b);
        }
        if(!v[a.x*2]&&a.x*2>=0&&a.x*2<=100000)
        {
            b.x = a.x*2;
            v[b.x] = 1;
            b.step = a.step+1;
            q.push(b);
        }
    }

}

int main()
{
    int t, i, j, v1, v2, k;
    while(~scanf("%d %d", &n, &m))
    {
        printf("%d\n", bfs(n));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值