POJ1035-Spell checker(字符串,模拟)

POJ1035 原题链接:http://poj.org/problem?id=1035

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25949 Accepted: 9505

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

题目大意:先输入一部字典以'#'结束,再输入单词以'#'结束,问输入的单词能否在字典中找到;

1.若找到输出 xx is correct;

2.若可以通过 改变 删除 增加 一个字母在字典中找到则输出字典中的单词(若有多个,顺序按照字典序);

3.若无法找到则不输出;


思路:暴力模拟就行,不难但是超麻烦,硬着头皮写就能写完;



代码如下(自己的代码被我弄丢了,这里参考了http://coco-young.iteye.com/blog/1343785的代码)

#include<stdio.h>  
#include<string.h>  
#define SIZE 11000  
char dic[SIZE][20];  
int cnt;  
void read_dic()//读取字典  
{  
     cnt = 0;  
     while(scanf("%s%*c",dic[cnt]))  
     {  
        if(dic[cnt][0]=='#')  
        break;  
        else  
        cnt++;  
     }  
}  
bool isCor(char *str)//是否正确   
{  
     int i;  
     for(i=0;i<cnt;i++)  
     if(strcmp(dic[i],str)==0)return true;  
     return false;  
}   
void Replace(char *str)//替换  
{  
     printf("%s:",str);  
     int i,j,k,arr[20],diff,isSort;  
     int ls = strlen(str),ld;  
     for(i=0;i<cnt;i++)  
     {  
        ld = strlen(dic[i]);  
        if(ls==ld)//如果长度相同   
        {  
            diff = 0;  
            for(j=0;j<ld;j++)  
            {  
               if(str[j]!=dic[i][j]) diff++;  
            }  
            if(diff==1)printf(" %s",dic[i]);  
        }  
        else if(ls==ld+1)//delete  
        {  
            memset(arr,-1,sizeof(arr));  
            for(j=0;j<ld;j++)  
            {  
               for(k=j==0?0:arr[j-1]+1;k<ls;k++)  
               {  
                  if(str[k]==dic[i][j])  
                  {  
                      arr[j] = k;  
                      break;  
                  }  
               }  
            }  
            isSort = 1;  
            //检查arr是否有序  
            for(j=0;j<ld-1;j++)  
            {  
               if(arr[j+1]<arr[j]||arr[j]==-1)  
               {  
                  isSort = 0;  
                  break;  
               }  
            }   
            if(arr[ld-1]==-1)isSort = 0;  
            if(isSort)printf(" %s",dic[i]);  
        }  
        else if(ls+1==ld)//add  
        {  
            memset(arr,-1,sizeof(arr));  
            for(j=0;j<ls;j++)  
            {  
               for(k=j==0?0:arr[j-1]+1;k<ld;k++)  
               {  
                  if(str[j]==dic[i][k])  
                  {  
                      arr[j] = k;  
                      break;  
                  }  
               }  
            }  
            isSort = 1;  
            //检查arr是否有序  
            for(j=0;j<ls-1;j++)  
            {  
               if(arr[j+1]<arr[j]||arr[j]==-1)  
               {  
                  isSort = 0;  
                  break;  
               }  
            }   
            if(arr[ls-1]==-1)isSort = 0;  
            if(isSort)printf(" %s",dic[i]);  
        }  
     }  
}   
int main()  
{  
    //freopen("in.txt","r",stdin);  
    //freopen("out.txt","w",stdout);  
    read_dic();  
    char str[20];  
    while(scanf("%s%*c",str),str[0]!='#')  
    {  
        if(isCor(str))  
        printf("%s is correct\n",str);  
        else  
        {  
           Replace(str);  
           printf("\n");  
        }  
    }  
}  



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值