POJ 1035 Spell checker

Spell checker

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
题目大意:写一个拼写检查器,如果被检查的字符串与字典中的某个字符串有一处不同的话,则可以进行以下操作并输出“原字符串:替换后的字符串”

(1)从被检查的字符串中删除一个字符

(2)以任意字母替换被检查字符串中的一个字符

(3)向被检查的字符串中插入任意一个字母

如果被检查的字符串与字典中的某个字符串相同的话,则输出“被检查的字符串 is corect”

解题思路:对于每个被输入的字符串,与字典中的字符串逐一进行对比,如果相等则输出正确,如果字典中没有字符串与它相等,那么再将它与字典中的字符串逐个字符进行比较,如果不同之处多于1处,则不进行处理;如果不同之处等于1处再进行输出处理。

代码如下:

#include <cstdio>
#include <cstring>
#include <cstdlib>

const int maxn = 10005;
char dic[maxn][20];
char word[20];

bool replace(char *a,char *b)
{
	int lena = strlen(a);
	int lenb = strlen(b);
	int i = 0;
	//如果两个字符串长度相等 
	if(lena == lenb){
		while(i < lena && a[i] == b[i])
			i++;//第一个不相等位置
		//如果后面还有字符不等的情况,说明不相同的字符数大于1,返回false 
		while(++i < lena)
			if(a[i] != b[i])
				return false;
	}else if(lena  + 1== lenb){//串a比串b长一个字符 
		while(i < lena && a[i] == b[i])
			i++;//第一个不相同的字符 
		while(++i < lenb)
			if(a[i - 1] != b[i])
				return false;
	}else if(lena == lenb + 1){//串b比串a长一个字符 
		while(i < lenb && a[i] == b[i])
			i++;
		while(++i < lena)
			if(a[i] != b[i- 1])
				return false; 
	}else{//串a与串b长度相差2或以上 
		return false;
	}
	return true;
}


int main()
{
	int i,j,k;
	i = 0;
	while(scanf("%s",dic[i++]) != EOF && strcmp(dic[i - 1],"#") != 0)
		;
	i--;
	while(scanf("%s",word) && strcmp(word,"#") != 0){
		bool flag = false;
		for(j = 0;j < i;j++){
			if(strcmp(dic[j],word) == 0){
				flag = true;
				break;
			}
		}
		if(flag){
			printf("%s is correct\n",word);
		}else{
			printf("%s:",word);
			for(j = 0;j < i;j++){
				if(replace(dic[j],word))
					printf(" %s",dic[j]);
			}
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值