IP Address

Problem Description

Suppose you are reading byte streams from any device, representing IP
addresses. Your task is to convert a 32 characters long sequence of
‘1s’ and ‘0s’ (bits) to a dotted decimal format. A dotted decimal
format for an IP address is form by grouping 8 bits at a time and
converting the binary representation to decimal representation. Any 8
bits is a valid part of an IP address. To convert binary numbers to
decimal numbers remember that both are positional numerical systems,
where the first 8 positions of the binary systems are: 27 26 25
24 23 22 21 20

128 64 32 16 8 4 2 1

Input

The input will have a number N (1<=N<=9) in its first line
representing the number of streams to convert. N lines will follow.

Output

The output must have N lines with a doted decimal IP address. A dotted
decimal IP address is formed by grouping 8 bit at the time and
converting the binary representation to decimal representation.

Sample Input

4
00000000000000000000000000000000 00000011100000001111111111111111
11001011100001001110010110000000 01010000000100000000000000000001

Sample Output

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1

题目大意:给定一串数字用二进制表示,没 八个数表示一个二进制
代码:

#include<stdio.h>
#include <string.h>
int num[8] = {128, 64, 32, 16, 8, 4, 2, 1};
int main()
{
	int N,i,j;
	char str[35];
	scanf("%d",&N);
	while(N--)
	{
		scanf("%s",str);
		int len=strlen(str);
		j =0;
		for( i=0; i<len; i++)
		{
			if(i%8 == 0&& i)
			{
				printf("%d",j);
				printf(".");
				j = 0;
			}
			j+= (str[i] - '0') * num[i % 8];
		}
		printf("%d\n",j);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值