UVA465 Overflow (2147483647,atof())

Write a program that reads an expression consisting of two non-negative integer and an operator.
Determine if either integer or the result of the expression is too large to be represented as a “normal”
signed integer (type integer if you are working Pascal, type int if you are working in C).
Input
An unspecified number of lines. Each line will contain an integer, one of the two operators ‘+’ or ‘*’,
and another integer.
Output
For each line of input, print the input followed by 0-3 lines containing as many of these three messages
as are appropriate: ‘first number too big’, ‘second number too big’, ‘result too big’.
Sample Input
300 + 3
9999999999999999999999 + 11
Sample Output
300 + 3
9999999999999999999999 + 11
first number too big
result too big

#include <stdio.h>
#include <string.h>
#include<stdlib.h>
int main()
{
    char s[600],n[600],c;
    double z,x,y;
    while(scanf("%s %c %s",s,&c,n)!=EOF)
        {
           printf("%s %c %s\n",s,c,n);
           x=atof(s);
           y=atof(n);
           if(c=='*')z=x*y;
           if(c=='+')z=x+y;
           if(x>2147483647)printf("first number too big\n");//2147483647
Integer在JAVA内用32位表示,因此32位能表示的最大值是2147483647。
           if(y>2147483647)printf("second number too big\n");
           if(z>2147483647)printf("result too big\n");
        }
    return 0;
}

atof()

头文件:#include <stdlib.h>

函数 atof() 用于将字符串转换为双精度浮点数(double),其原型为:
double atof (const char* str);

atof() 的名字来源于 ascii to floating point numbers 的缩写,它会扫描参数str字符串,跳过前面的空白字符(例如空格,tab缩进等,可以通过 isspace() 函数来检测),直到遇上数字或正负符号才开始做转换,而再遇到非数字或字符串结束时('\0')才结束转换,并将结果返回。参数str 字符串可包含正负号、小数点或E(e)来表示指数部分,如123. 456 或123e-2。

【返回值】返回转换后的浮点数;如果字符串 str 不能被转换为 double,那么返回 0.0。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值