hdu 1002 A + B Problem II (大数相加)

7 篇文章 0 订阅

链接:hdu 1002

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

解析:本题就是模拟的数学算数相加,可以从个位开始相加,超过10就先前进位


AC代码:

#include<stdio.h>
#include<string.h>
char s[1010],s1[1010],s2[1010];
void add()
{
    int i,j,k,m,n;
    m=strlen(s1);
    n=strlen(s2);
    memset(s,0,sizeof(s));
    if(m>n)
        k=m-1;
    else
        k=n-1;
    for(i=m-1,j=n-1;i>=0||j>=0;i--,j--){
        if(i>=0&&j>=0)
            s[k]+=s1[i]+s2[j]-48;
        else if(i>=0&&j<0)
            s[k]+=s1[i];
        else if(i<0&&j>=0)
            s[k]+=s2[j];
        if(s[k]>'9'&&k){ //k为0时,不能往数组前一位进位,要另外判断
            s[k]-=10;
            s[k-1]++;
        }
        k--;
    }
}
int main()
{
    int i,T;
    scanf("%d",&T);
    for(i=1;i<=T;i++){
        scanf("%s%s",s1,s2);
        printf("Case %d:\n%s + %s = ",i,s1,s2);
        add();
        if(s[0]>'9'){   //最高位为0时
            s[0]-=10;
            printf("1");
        }
        printf("%s\n",s);
        if(i!=T)
            printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值