hdu 2433 Travel(最短路径数思想)

Travel

Time Limit: 10000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2616    Accepted Submission(s): 861


Problem Description
      One day, Tom traveled to a country named BGM. BGM is a small country, but there are N (N <= 100) towns in it. Each town products one kind of food, the food will be transported to all the towns. In addition, the trucks will always take the shortest way. There are M (M <= 3000) two-way roads connecting the towns, and the length of the road is 1.
      Let SUM be the total distance of the shortest paths between all pairs of the towns. Please write a program to calculate the new SUM after one of the M roads is destroyed.

 

Input
      The input contains several test cases.
      The first line contains two positive integers N, M. The following M lines each contains two integers u, v, meaning there is a two-way road between town u and v. The roads are numbered from 1 to M according to the order of the input.
      The input will be terminated by EOF.

 

Output
      Output M lines, the i-th line is the new SUM after the i-th road is destroyed. If the towns are not connected after the i-th road is destroyed, please output “INF” in the i-th line. 
 

Sample Input
  
  
5 4 5 1 1 3 3 2 5 4 2 2 1 2 1 2
 

Sample Output
  
  
INF INF INF INF 2 2
题意:给你n个点m条边,依次输出销毁第i条边后图上是不是两两连通,如果是则输出所有边的长度。

思路:常规的做法是每次销毁一条边就求n次最短路,但是这样时间复杂度达到了O(mn²logn),必然会TLE。

所以我们可以预处理求n次最短路并记录下每一次经过了哪些边,那么如果我们销毁的边不在最短路径上就不必再求一次最短路了。如果销毁的路有多条,也不必再求了。

所以我们只需对仅有一条且在最短路径上的边进行最短路的求解。 这也被称为最短路径树的思想。注意这里我用迪杰斯特拉就会超时,用spfa就过了,可能是因为对于这道题,边比较少。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 110
#define M 3050
#define INF 1<<28
int n,m;
int d[N],vis[N];
int cnt,head[N];
int used[N][N][N];
int sum[N],pre[N],num[N][N];
struct Edge
{
    int v,next,w;
} edge[M*2];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
    memset(used,0,sizeof(used));
    memset(num,0,sizeof(num));
    memset(sum,0,sizeof(sum));
}
void addedge(int u,int v,int w)
{
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int spfa(int s,int t)
{
    queue<int> q;
    for(int i=1;i<=n;i++)
        d[i]=INF,vis[i]=0;
    d[s]=0,vis[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].v,w=edge[i].w;
            if(d[u]+w<d[v])
            {
                d[v]=d[u]+w;
                if(!vis[v])
                {
                    if(!t) used[s][u][v]=used[s][v][u]=1;
                    q.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    int ans=0;
    for(int i=1; i<=n; i++)
    {
        if(d[i]==INF) return INF;
        ans+=d[i];
    }
    return ans;
}
int main()
{
    int u,v,mark,ans,s,t;
    while(~scanf("%d %d",&n,&m))
    {
        ans=0;
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%d %d",&u,&v);
            addedge(u,v,1);
            addedge(v,u,1);
            num[u][v]++,num[v][u]++;
        }
        for(int i=1; i<=n; i++)
        {
            sum[i]=spfa(i,0);
            if(sum[i]==INF)
            {
                ans=INF;
                break;
            }
            ans+=sum[i];
        }
        for(int i=0; i<m; i++)
        {
            s=ans;
            if(ans==INF)
            {
                printf("INF\n");
                continue;
            };
            if(num[edge[i*2+1].v][edge[i*2].v]>1)
            {
                printf("%d\n",ans);
                continue;
            }
            edge[i*2].w=edge[i*2+1].w=INF;
            for(int j=1; j<=n; j++)
                if(used[j][edge[i*2+1].v][edge[i*2].v])
                {
                    t=spfa(j,1);
                    if(t==INF)break;
                    s=s-sum[j]+t;
                }
            if(t==INF) printf("INF\n");
            else printf("%d\n",s);
            edge[i*2].w=edge[i*2+1].w=1;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值