hdu 5461 Largest Point(杂题)

Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1485    Accepted Submission(s): 588


Problem Description
Given the sequence  A  with  n  integers  t1,t2,,tn . Given the integral coefficients  a  and  b . The fact that select two elements  ti  and  tj  of  A  and  ij  to maximize the value of  at2i+btj , becomes the largest point.
 

Input
An positive integer  T , indicating there are  T  test cases.
For each test case, the first line contains three integers corresponding to  n (2n5×106), a (0|a|106)  and  b (0|b|106) . The second line contains  n integers  t1,t2,,tn  where  0|ti|106  for  1in .

The sum of  n  for all cases would not be larger than  5×106 .
 

Output
The output contains exactly  T  lines.
For each test case, you should output the maximum value of  at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
题意,给你n个点和a,b,找出两个不同的点使得 at2i+btj .的值最大

思路:分四种情况讨论即可。

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include <stdlib.h>
#include<math.h>
#include<algorithm>
using namespace std;
typedef long long LL;
#define INF 999999999
int main(){
    int tcase;
    scanf("%d",&tcase);
    int t =1;
    while(tcase--){
        LL IMAX=-INF,ISMAX=-INF,IMIN=INF,ISMIN=INF; ///ti平方的最大次大最小次小
        LL JMAX=-INF,JSMAX=-INF,JMIN=INF,JSMIN=INF; ///tj的最大次大最小次小
        int n;
        LL a,b;
        int id1,id2,id3,id4; ///ti 最大最小 tj最大最小
        scanf("%d%lld%lld",&n,&a,&b);
        for(int i=1;i<=n;i++){
            LL NUM,TEMP;
            scanf("%lld",&NUM);
            TEMP = NUM*NUM;
            if(NUM<JMIN){
                JSMIN = JMIN;
                JMIN = NUM;
                id2 = i;
            }else JSMIN = min(JSMIN,NUM);
            if(NUM>JMAX){
                JSMAX = JMAX;
                JMAX = NUM;
                id1 = i;
            }else JSMAX = max(JSMAX,NUM);
            if(TEMP<IMIN){
                ISMIN = IMIN;
                IMIN = TEMP;
                id4 = i;
            }else ISMIN = min(ISMIN,TEMP);
            if(TEMP>IMAX){
                ISMAX = IMAX;
                IMAX = TEMP;
                id3 = i;
            }else ISMAX = max(ISMAX,TEMP);
        }
        LL ans = 0;
        if(a>=0&&b>=0){
            if(id3!=id1) ans = a*IMAX+b*JMAX;
            else ans = max(a*ISMAX+b*JMAX,a*IMAX+b*JSMAX);
        }else if(a>0&&b<0){
            if(id3!=id2) ans = a*IMAX+b*JMIN;
            else ans = max(a*ISMAX+b*JMIN,a*IMAX+b*JSMIN);
        }else if(a<0&&b>0){
            if(id4!=id1) ans = a*IMIN+b*JMAX;
            else ans = max(a*ISMIN+b*JMAX,a*IMIN+b*JSMAX);
        }else {
            if(id4!=id2) ans = a*IMIN+b*JMIN;
            else ans = max(a*IMIN+b*JSMIN,a*ISMIN+b*JMIN);
        }
        printf("Case #%d: %lld\n",t++,ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值