hdu 1005 Number Sequence(循环节)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 149591    Accepted Submission(s): 36421


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
题意:求f[n]

思路:f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7 

n达到了1E,不可能暴力枚举。那么我们怎么解呢?

注意对于任意f[n],值域都是[0,7)一个七个数字,A与B又是确定的,我们就可以知道这个序列必然存在循环节。

想想,最坏情况下(f[i-1],f[i-2])到(f[i+47],f[i+46])连续49个值都不一样,但是,第50个必然会出现这49个中的其中一个。

那么我们就只要比较当前面两项出现相同的就是循环节了,循环最多50*49次,轻松过。注意循环节第一个不一定是1,1

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
int f[100];
int main()
{
   int a,b,n;
   int start,num;
   while(~scanf("%d %d %d",&a,&b,&n))
   {
       if(!a&&!b&&!n) break;
       f[1]=1,f[2]=1;
       f[3]=(a*f[2]+b*f[1])%7,f[4]=(a*f[3]+b*f[2])%7;
       start=0,num=0;
       for(int i=5;i<=60;i++)
       {
           for(int j=3;j<i;j++)
           {
               if(f[i-2]==f[j-2]&&f[i-1]==f[j-1])
                {
                    num=i-j;
                    start=j;
                    break;
                }
           }
           if(start) break;
           f[i]=(a*f[i-1]+b*f[i-2])%7;
       }
       if(n>=start) n=start+(n-start)%num;
       printf("%d\n",f[n]);
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值