hdu 2620 Ice Rain(数论)

Ice Rain

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 181    Accepted Submission(s): 76


Problem Description
Ice Rain------I was waiting for a girl, or waiting for been addicted to the bitter sea. Love for irrigation in silence. No one considered whether the flowers came out or wither. Love which I am not sure swing left and right. I had no choice but to put my sadness into my heart deeply.

   Yifenfei was waiting for a girl come out, but never. 
His love is caught by Lemon Demon. So yifenfei ’s heart is “Da Xue Fen Fei” like his name.
The weather is cold. Ice as quickly as rain dropped. Lemon said to yifenfei, if he can solve his problem which is to calculate the value of   , he will release his love.
Unluckily, yifenfei was bored with Number Theory problem, now you, with intelligent, please help him to find yifenfei’s First Love.
 

Input
Given two integers n, k(1 <= n, k <= 10 9).
 

Output
For each n and k, print Ice(n, k) in a single line.
 

Sample Input
  
  
5 4 5 3
 

Sample Output
  
  
5 7
题意:给你n和k,求

思路:kmodi=k-i*[k/i] ,所以=nk-(1*[k/1]+2*[k/2]+...+n*[k/n])

那么问题就在于怎么求解(1*[k/1]+2*[k/2]+...+n*[k/n]),直接枚举肯定会炸掉

我们知道[k/i]到[k/n]肯定是分成很多段值相等的区间的。(k固定,n越小k/n越大,但是中间会有几个数k/n值是相同的,比如4/3=1 4/4=1)

对于某些区间来说,数量是很庞大的,所以如果我们可以已知这个区间的第一个编号,求得区间最后一个编号,那么将大大加快枚举时间。

设d=k/i  j=k/d则j就是我们要求的最后一个编号,每次到i后直接跳到j+1即可。

证明:

已知d=k/i,我们要求一个j使得[i,j]之间的数l的[k/l]=d

那么令j=k/d,[i,j]内的数满足性质是显而易见的。但是j是不是区间的最后一个数呢?

我们假设k/(j+1)=d,那么有d(j+1)<=k  而根据k/d=j可以推出k-(d*j)<d即k<d*(j+1)

这就冲突了吧。 

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
int main()
{
    LL n,k;
    while(~scanf("%lld %lld",&n,&k))
    {
        LL ans=n*k;
        if(n>k) n=k;
        for(LL i=1;i<=n;)
        {
            LL d=k/i;
            LL j=k/d;
            if(j>n) j=n;
            ans=ans-d*((i+j)*(j-i+1)/2);
            i=j+1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值