hdu 2674 N!Again(数论,水题)

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4739    Accepted Submission(s): 2500


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
  
  
24 120
题意:求n的阶乘%2009

思路:首先对与大于等于2009的数,结果必为0应该是显然的,因为阶乘中间必然会出现2009,那么必然可以整除了。

其实这个性质对于2009的最大质因子也是等价的,只要n大于等于2009的最大质因子,阶乘过程中必然会整除2009所有质因子,也就是整除2009本身了。

2009最大质因子只有41,所以当n>=41时输出0,否则O(n)跑一遍阶乘取模即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
int devide(int n)
{
    int maxn=-1;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            maxn=i;
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1) maxn=n;
    return maxn;
}
int main()
{
    int n;
    int m=devide(2009);
    while(~scanf("%d",&n))
    {
        if(n>=m) printf("0\n");
        else
        {
            LL ans=1;
            for(int i=2;i<=n;i++)
                ans=ans*i%2009;
            printf("%lld\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值